Flakey Behaviour

Discussion in 'General' started by BorderAmigos, May 14, 2008.

  1. BorderAmigos

    BorderAmigos New Member

    I have ISPConfig set up on an AMD64 system running Fedora 8. There are 31 domain names set up. The best I have gotten is 30 to work. Always at least one doesn't respond even though they are all set up identically.

    Yesterday 30 worked. The machine was shut down over night then powered on today. Now about 25 work. Nothing changed other than being turned off for a couple hours. Some have the domain.xxx working but not the www.domain.xxx which worked yesterday.

    So why do I seem to have this hard limit of 30 domains and why does it stop working after reboot? Any suggestions are appreciated. Thanks.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no such limits in ISPConfig, if you did not limit the number of domains in the reseller settings. But even that would not cause the behaviour that you describe.

    Have a look in the ISPConfig interface and in the Vhost_ispconfig.conf file if all domains are listed there properly.
  3. BorderAmigos

    BorderAmigos New Member

    All domains appear and are configured the same (except the domain name obviously) in the ISPConfig interface and in the Vhosts_ispconfig.conf file. Yet the behaviour still exists. Maybe something in DNS? The zones for the DNS entries appear to be configured the same at my registrars entries. I'm stumped so far.

    PS - I don't have any reseller entries. Each domain is has a client entry and each of the client entries has 1 site and 1 co-domain for www.
  4. falko

    falko Super Moderator ISPConfig Developer

    Do you run the name server for the domains yourself? On the same system that you power down?
  5. BorderAmigos

    BorderAmigos New Member

    The domain registry points to their name servers. Their DNS in turn has zones pointing each domain to my machine which has BIND configured by ISPConfig.
  6. BorderAmigos

    BorderAmigos New Member

    The problem was with my domain registrars name servers. All seems well for the moment.
  7. BorderAmigos

    BorderAmigos New Member

    And one day later the problems return. :confused:
  8. falko

    falko Super Moderator ISPConfig Developer

    If the name server is running on the machine that you power off, I think you get some problems with caching name servers - if they try to resolve one of your domains while BIND is down, they'll cache that the domain cannot be resolved, I guess.

Share This Page