Following Perfect Setup Fedora 4 Proftpd Fails on start

Discussion in 'Installation/Configuration' started by dutchman, Feb 7, 2006.

  1. dutchman

    dutchman New Member

    We are trying to install proftpd

    We built a Fedora Core 4 box. It was working great until we tried to use FTP (vsftpd). It would not permit a upload. Downloads worked fine.

    We could not get it to work so we decided to try proftpd. We followed the Perfect Setup - Fedora Core 4 from

    We jumped to the proftpd setup page. The yum install seemd to work with no problems. The

    chkconfig --levels 235 proftpd on returned No errors.

    We then attempted the start and it fails every try.
  2. falko

    falko Super Moderator Howtoforge Staff

    Do you get error messages when you try to start ProFTPd?

    Please post the output of
    netstat -tap
  3. dutchman

    dutchman New Member



    We used yum to un-install proftpd. We then use yum to install and it will now start. However, we are having a permissions problem.

    We can FTP to the server. We can transfer a file from the server to our remote work station. However, we can not transfer from our work station to the server. We have been combing all of the articles about insatlling and configuring PROFTPD but have been unsuccessful. I will attach the results of the netstat -tap although I am assuming that is no longer necessary.

    Thanks for your help.

  4. dutchman

    dutchman New Member

    Oops! proftpd

    I forgot to attach the netstat

    [root@crosnetmon03 pam.d]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:32769 *:* LISTEN 1568/rpc.statd
    tcp 0 0 *:sunrpc *:* LISTEN 1550/portmap
    tcp 0 0 *:ftp *:* LISTEN 4614/proftpd: (acce
    tcp 0 0 *:ssh *:* LISTEN 1949/sshd
    tcp 0 0 localhost:ipp *:* LISTEN 1896/cupsd
    tcp 0 0 localhost:5335 *:* LISTEN 1861/mDNSResponder
    tcp 0 0 localhost:smtp *:* LISTEN 2008/sendmail: acce
    [root@crosnetmon03 pam.d]#
  5. falko

    falko Super Moderator Howtoforge Staff

    Please post the output of
    ls -la /path/to/ftp_directory
    and also, as which user you're logging in with FTP.

Share This Page