Freeradius Radtest error

Discussion in 'HOWTO-Related Questions' started by Camomille, Jan 3, 2009.

  1. Camomille

    Camomille Member


    I am actually struggling for hours with a freeradius config problem. Sure I made a stupid error but can't find it out anymore now.

    here is the output of radtest command
    [[email protected] /]# radtest root amazone_zanzibar localhost 1812 Amaz0ne2007
    radclient:: Failed to find IP address for amazone
    [[email protected] /]#
    here is a piece of my clients.conf:

    client {
           netmask = 32
    	secret		= Amaz0ne2007
    	require_message_authenticator = no
    	shortname	= buffalo
    	nastype     = other	# localhost isn't usually a NAS...
    and here is a line of my users file:
     root	Cleartext-Password := "amazone_zanzibar
    Can anyone please show me where I'll find my error(s) ?

    For info, Freeradius is installed on a CentOS 5.2 Virtual Machine (The Perfect server... from here ;) )

    GREAT Thanks in advance.

    Greetings to all.

  2. awan

    awan New Member


    see if u have localhost client setup in clients.conf file.
    furthermore verify if ur able to ping to localhost
    i.e. "ping localhost"
    if not then fix it in /etc/hosts file
    but I would guess that u have removed the localhost client (access point) from the clients.conf file
    also check for the typos
    e.g. root Cleartext-Password := "amazone_zanzibar"""""""
    Good luck

    Note: the is a complete howto regarding freeradius on centos 5.2 on howtoforge. do check it out.
    Neil Brodzik likes this.
  3. Camomille

    Camomille Member

    Thanks for your answer and all my excuses for the very late reply.

    You helped me when talking about /etc/hosts file. I had simply and partially changed the machine name by editing /etc/sysconfig/network” file. I have now corrected /etc/hosts file properly and don't have this error when launching radtest.
    Other and new errors should be sorted shortly ;) ;)

    Great thanks again for your precious help.

  4. awan

    awan New Member


    ur welcome
  5. raduser

    raduser New Member

    Failed to find IP

    Hi Camomille,

    I have the same problem with IP.

    When I run 'radtest test test localhost 10 testing123 ' I had:

    Failed to find IP address for fedora.

    I saw you changed the /etc/sysconfig/network” file.

    What kind of changes need this file?

    Greetings to all.

  6. awan

    awan New Member

    Ruslan ?

    just fix the FQDN.
    For you it seems the command ¨system-config-network¨ is more suited.
    it would automatically take care of that /etc/sysconfig/.. file as well as /etc/hosts
    After reboots & everything etc.. just verify that ur have correct FQDN.
    hostname, domainname commands may come in handy. not to mention the good´ol ping.

    btw 1810 is the default port not just 10.

  7. Neil Brodzik

    Neil Brodzik New Member

    Fixing the hosts file worked for me. Thanks!

Share This Page