fstab issue

Discussion in 'Installation/Configuration' started by anthonywang, Apr 26, 2017.

  1. anthonywang

    anthonywang Member

    in this document
    # /etc/fstab: static file system information.
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    # <file system> <mount point> <type> <options> <dump> <pass>
    /dev/mapper/server1--vg-root / ext4 errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1
    # /boot was on /dev/sda1 during installation
    UUID=39762f15-3a49-4982-add3-139d5040b48a /boot ext2 defaults 0 2
    /dev/mapper/server1--vg-swap_1 none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    but when i open the file
    there are just
    LABEL=cloudimg-rootfs    /    ext4    defaults    0 0
    what should i do?add all text from document or?
    many thanks!
    Last edited: Apr 26, 2017
  2. edu_tomasi

    edu_tomasi New Member

    Hello Anthony.

    You can use the package "e2label" to define a label for block devices...
    Because of this we see that way of inform an mount point in your fstab archive.
    But you also can use 'blkid' to mount your device.

  3. ChristianC123

    ChristianC123 New Member

    The device or partition is required to be labeled first. To do this, you can use common applications like gparted to label partitions or you can use e2label to label ext2, ext3, and ext4 partitions. Keep in mind that not all file system have labeling support (e.g. FAT file systems). Labels can be up to 16 characters long. Labels should be unambiguous, meaning that each label should be original to prevent any possible conflicts.

    # <file system> <dir> <type> <options> <dump> <pass>
    LABEL=Debian / ext4 defaults 1 1

    Last edited: Jun 21, 2017
  4. Stephan Ververda

    Stephan Ververda Member HowtoForge Supporter

    it's a lot simpler actually extend your existing line
    LABEL=cloudimg-rootfs    /    ext4    defaults    0 0
    to this:
    LABEL=cloudimg-rootfs    /    ext4    defaults,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0    0 0

Share This Page