FTP access with Dreamweaver / FTPclient

Discussion in 'Installation/Configuration' started by pjm2211, Oct 28, 2005.

  1. pjm2211

    pjm2211 New Member

    First of all, this was an awesome article and the best How-To I've done yet. Got my webserver up and running and hosting my first site. The web-ftp function works great but I would like to connect to my site directly with dreamweaver or another ftp client but my ftp username/password are not working. I am using the user account that I created as Admin.

    Any suggestions would be great as I have reached a bump in the road. I read another thread here that was similar, and the guy said he logged into his admin account, and removed ftp access, saved, and then rechecked ftp access, and resaved, and it worked for him. I tried that but when i uncheck ftp access and save......I go back to it, and it is still checked, it's like it won't let me uncheck ftp access.

    Please help...lol
  2. falko

    falko Super Moderator Howtoforge Staff

    First make sure your firewall doesn't block port 21 (FTP) on your ISPConfig box.

    Also, have you tried "Passive Mode" in Dreamweaver's ftp settings?
  3. pjm2211

    pjm2211 New Member

    I checked my settings and the firewall on ispconfig is actually turned off. I also tried the "passive FTP" on dreamweaver and still no luck.. :(
  4. Lil'Brudder

    Lil'Brudder New Member


    I use Dreamweaver to connect to my server also, and I haven't had any problems at all. The only thing I set was the domain name, my user name, and the password. I'm not using passive, I'm not using SecureFTP, or anything else, and it works great.

    Is your server behind a router? Is port 21 forwarded to the server on the router? Are you using the right username for the site?
  5. kanal42

    kanal42 New Member

    FTP Problems ... here too


    some of my customers have FTP problems. Untill now it looks strange - the can't connect to the server - I can. They can connect to other servers, so no FW problem. Besides they can login (I see in the log) but then they get a timeout, which sounds like act/pass problem too me. I had to switch to active mode, before this never worked. I am just trying to figure out. Here my proFTP conf (deleted all commented lines):

    ServerName			"Debian"
    ServerType			standalone
    DeferWelcome			off
    MultilineRFC2228		on
    DefaultServer			on
    ShowSymlinks			on
    TimeoutNoTransfer		600
    TimeoutStalled			600
    TimeoutIdle			1200
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                	"-l"
    DenyFilter			\*.*/
    DefaultRoot 			~
    IdentLookups 			off
    ServerIdent on "FTP Server ready."
    Port				21
    MaxInstances			30
    User				nobody
    Group				nogroup
    Umask				022  022
    AllowOverwrite			on
    DefaultRoot ~
    Include /etc/proftpd_ispconfig.conf
    and here the ispconf-part:
    <VirtualHost xx.xx.xx.xx>
            DefaultRoot             ~
            AllowOverwrite          on
            Umask                   002
    Any help welcome - I'll check on the proftp site now,

    regards maik
  6. kanal42

    kanal42 New Member

    shell access?

    I don't know, but may the ftp-user must have shell access. As I just read on the proftpd site, the option

    DefaultRoot ~
    will make a chroot as soon, as the user logs in, so the ftp-session can run in a kind of sandbox. If the user hasn't got shell access, this might end up in

    $> chroot /dev/null
    -> timeout! :). So try it and give the ftp user shell access...then retry. If possible you can check the

    regards maik
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you check the "FTP" Checkbox in the site settings, ISPCOnfig gives the FTP user a correct shell. With thsi shell the user can use FTP but not login with SSH.
  8. falko

    falko Super Moderator Howtoforge Staff

    Please post the output of
    netstat -tap
    I'd like to see if your FTP server is listening only on certain IP addresses such as (localhost).

    When you tried to connect with Dreamweaver, did you use your server's IP address or a hostname? If you used a hostname, can you try again with the IP address?
  9. falko

    falko Super Moderator Howtoforge Staff

    As Till has posted before, you have to enable "FTP Access" on the "Basis" tab of a web site. Then you don't have to give your users shell access.
  10. pjm2211

    pjm2211 New Member

    I have given the site FTP access on the basis tab. I've also tried to connnect via ip address as well. No luck thus far. I don't have telnet working so I have to go to my data center to get the netstat -tap, and to check for ftp shell access. Will post my findings.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Dont you have SSH on your Server and can use putty to connect to it? Dont install Telnet, it is to insecure.
  12. pjm2211

    pjm2211 New Member

    I must admit that I am a linux newbie. Not sure if SSH is installed on my server or not. I would love to connect to it remotely, any help via a how-to link would be much appreciated. Thanks PJ
  13. falko

    falko Super Moderator Howtoforge Staff

  14. pjm2211

    pjm2211 New Member

    here is the output of netstat -tap

    [root@localhost var]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 2278/xinetd
    tcp 0 0 *:32769 *:* LISTEN 1930/rpc.statd
    tcp 0 0 *:pop3s *:* LISTEN 2278/xinetd
    tcp 0 0 *:mysql *:* LISTEN 2412/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 2278/xinetd
    tcp 0 0 *:imap *:* LISTEN 2278/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 1912/portmap
    tcp 0 0 *:81 *:* LISTEN 2725/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 4340/proftpd: (acce
    tcp 0 0 *:* LISTEN 2860/named
    tcp 0 0 *:* LISTEN 2860/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 2860/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 14858/cupsd
    tcp 0 0 *:telnet *:* LISTEN 2278/xinetd
    tcp 0 0 localhost.localdomain:5335 *:* LISTEN 2217/mDNSResponder
    tcp 0 0 *:smtp *:* LISTEN 4356/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2860/named
    tcp 0 0 wsip-68-96-20-200.om.:54815 TIME_WAIT -
    tcp 0 0 *:http *:* LISTEN 2764/httpd
    tcp 0 0 *:ssh *:* LISTEN 2269/sshd
    tcp 0 0 ::1:rndc *:* LISTEN 2860/named
    tcp 0 0 *:https *:* LISTEN 2764/httpd
    tcp 0 2892 ::ffff: wsip-68-96-20-200.om.:54756 ESTABLISHED 23607/1
    [root@localhost var]#
  15. pjm2211

    pjm2211 New Member

    to falko...

    ....SSH is installed, and putty does work...thank you much for that tip. saved me multiple trips to datacenter. Thanks again.
  16. pjm2211

    pjm2211 New Member

    ftp access...

    I SSH'd to my webserver...and was ablt to "ftp localhost"....and my sites admin username and password worked just fine. Still can't ftp to the webserver off the local machine though. Think it might be a router config problem?
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, it looks like a roter probelm. Have you forwarded the FTP Port on the router to your webserver? Have you tried passive FTP?
  18. pjm2211

    pjm2211 New Member

    I have a direct NAT from the outside ip to the inside ip setup in the router/firewall. everything else is working but the ftp. I have tried passive ftp using the domain name, the outside ip, and via the local ip over a vpn tunnel. No luck on any of them. :confused:

Share This Page