FTP and owncloud connections timouts ISPCONFIG3 and CentOS 7

Discussion in 'Installation/Configuration' started by vestport, Nov 12, 2014.

  1. vestport

    vestport Member

    Hello, having connection issues with both FTP and owncloud. FTP will eventually upload files but it is at a snails pace after it gets around the errors. I am simply trying to upload the Joomla 3 and have been waiting like 10 minutes so far. Also, owncloud fails uploading MP3's from either the web or client. I did hear that there may be some issues with ownlcloud uploading unless you use the client but I tried the client too. I suspect an issue with Pure-FTP but sure what to check. Something is bogging the uploads down. I have tried FireFTP and winscp and same results. Using passive mode with fireftp.

    The only thing that I did that may have mucked things up is edit the php.ini file for 200MB transfers & uploads and the max memory size to 512K. I'll try putting that back or lower.

    Any ideas?

    This was working like a top the other day. Not sure what is going on. I may just try to reboot.

    Any suggestions welcome.

    Thanks in advance for your reply!

  2. vestport

    vestport Member

    Owncloud errors

    Errors are "Internal Server Error" every few secondz or "Upload Cancelled" and nothing ever makes it there. One thing that I should mention is that I did the "</> Web Installer for Shared Hosts" versus a yum install. That should not make a difference right?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Which error messages do you get in the error.log file of the website?
  4. vestport

    vestport Member

    MaxRequestLen in Apache

    Hi Till,

    Looks like my "MaxRequestLen" in apache was not good enough. The actual error was:

    mod_fcgid: HTTP request length 138590 (so far) exceeds MaxRequestLen (131072)

    Therefore I adjusted the apache directives in vhost file to increase the size and life is good!:)

    For anyone else reading this: In ISPCONFIG > WEBSITES > OPTIONS my apache directive is:

    FcgidMaxRequestLen 200000000
    Also, my custom php.ini settings are:

    upload_max_filesize = 200M
    post_max_size = 200M
    memory_limit = 500M

    Thanks again for letting me know where to look (error.log of vhost)!!!!! It's been a while for me and I'm rusty.


Share This Page