FTP ISPConfig problem.. please help.....

Discussion in 'Installation/Configuration' started by rpavez, Jan 9, 2009.

  1. rpavez

    rpavez New Member

    I hope that someone could help me...

    I've install ispconfig following the ubuntu 8.04 perfect server how to... everething is fine... i create the sites.. no problem... the only one problem that i have is with the ftp... when i tried to connect with an ftp client... the user is recognized, the assword to... but it doesn't connect me to the folder of the site, via webFTP, the one who cames with ispconfig y have no connection problems.

    Could someone tell me what can be wrong????...

  2. stevieb_

    stevieb_ New Member

    check the /etc/passwd file
    the users need to have a shell in there
    the end of the line /bin/bash as opossed to /bin/false
  3. rpavez

    rpavez New Member

    This is te output of /etc/passwd

    list:x:38:38:Mailing List Manager:/var/list:/bin/sh
    gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
    mysql:x:108:115:MySQL Server,,,:/var/lib/mysql:/bin/false
    admispconfig:x:1001:1001:Administrator ISPConfig:/home/admispconfig:/bin/bash
    web6_admin:x:10004:10006:Rodrigo Pavez:/var/www/web6:/bin/bash
    web6_rpavez:x:10006:10006:Rodrigo Pavez:/var/www/web6/user/web6_rpavez:/bin/bash

    I'm trying with we6_admin and web6_rpavez, wahat do you mean with your suggetion?...

    And thanks fo replying
  4. stevieb_

    stevieb_ New Member

    apologies i misread the original post, i skim read it , and missed about it accepting the password .

    with the admin login it will drop you to


    and the other i twill drop you into


    is this about right?
    Last edited: Jan 9, 2009
  5. rpavez

    rpavez New Member

    It supose, but nither of the two accounts connect me with some specific folder.... i mean, i can't connect to the specific folder with any acout (with an ftp client)
  6. stevieb_

    stevieb_ New Member

    the admin account will drop you into the root folder of that website
    ie /var/www/web6/

    and in there you will have a "web" folder which is where the site is stored.

    the other user will drop you in their users folder as i imagine that they arent an admin
    ie /var/www/web6/user/web6_rpavez

    where do you want them to drop you?
    from the admin account you can just click on the web folder and then you have the website directory there
    from the user's folder add them as an admin then you can make your way to the web folder aswell.
    failing that what ive done is create sub folders to the website
    ie /var/www/web6/user1 and then put a symbolic link in the user folder which allows me to drop them into that folder :D
    i dont know if that will work for what you want, or even if it is what you are after.
  7. rpavez

    rpavez New Member

    The problem i not that..... i can upload files trough web ftp, the one who cames with ispconfig... but when i trie with n ftp client, the ftp client doesn't show me the folder...

    this is the output of the ftp client

    STATUS:> [09-01-2009 18:13:49] Connected. Authenticating...
    COMMAND:> [09-01-2009 18:13:49] USER web6_admin
    [09-01-2009 18:13:49] 331 Password required for web6_admin
    COMMAND:> [09-01-2009 18:13:49] PASS *****
    [09-01-2009 18:13:52] 230 User web6_admin logged in
    STATUS:> [09-01-2009 18:13:52] Login successful.
    COMMAND:> [09-01-2009 18:13:52] PWD
    [09-01-2009 18:13:52] 257 "/" is the current directory
    STATUS:> [09-01-2009 18:13:52] Home directory: /
    COMMAND:> [09-01-2009 18:13:52] FEAT
    [09-01-2009 18:13:52] Informational Message Only:
    211 End
    STATUS:> [09-01-2009 18:13:52] This site supports features.
    STATUS:> [09-01-2009 18:13:52] This site supports SIZE.
    STATUS:> [09-01-2009 18:13:52] This site can resume broken downloads.
    COMMAND:> [09-01-2009 18:13:52] REST 0
    [09-01-2009 18:13:52] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer
    COMMAND:> [09-01-2009 18:13:52] PASV
    ERROR:> [09-01-2009 18:13:52] Can't read from control socket. Socket error = #10054.
    ERROR:> [09-01-2009 18:13:52] Failed to establish data socket.
  8. stevieb_

    stevieb_ New Member

    you need to rule out a fair bit first.
    can you connect to other ftp servers from that client?

    have you tried connecting to your server from a dos box?

    with that client, have you tried changing it from pasv, to port ?
  9. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client?
  10. rpavez

    rpavez New Member

    Thanks both for the concern... i tried connct to another ftp with the cilent... an there's no problem.... I've tried every way of connection...

    i've being searhing for a week and nothing....
  11. falko

    falko Super Moderator ISPConfig Developer

    Ok, this sounds like a firewall problem. Can you try to switch off the firewall on the server (or any router that sits between you and the server)?
  12. newmember

    newmember New Member

    More specifically, its probably a Passive FTP config issue with the firewall and ftp server config.
    If you select NOT passive on your FTP client and try to see the directory listings, if you see the directory listings you have a Passive FTP config issue.

Share This Page