FTP login fails

Discussion in 'Installation/Configuration' started by bradprin, Sep 23, 2009.

  1. bradprin

    bradprin New Member

    So I'm a linux newbie. I setup my ubuntu 8.04 server using the ispconfig3 perfect server tutorial (thanks very much for that tutorial by the way) and having gotten to the end of it I've created a website and am trying to add an FTP user to that website. I go to the FTP users page and add a new user to my website mydomain.com, let all the quota settings stay at -1, and made the username be bradley1. I get this error:

    Connected to
    220 FTP Server ready.
    Name ( bradley1
    331 Password required for bradley1
    530 Login incorrect.
    ftp: Login failed

    I'm logging in from the local network so it shouldn't be a port issue (I'm also connecting to the server so it definitely shouldn't be a port issue). I'm just not sure even where to look next. Any ideas?
  2. bradprin

    bradprin New Member

    Oh, also I've tried resetting the password and it doesn't seem to make a difference.
  3. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client?
  4. bradprin

    bradprin New Member

    Ok, I think I figured it out.

    When I try to FTP to my website using my IP address there is no name for ISPConfig to resolve to a website. For example, when I added www.mydomain.com to my hosts file and tried to log in, it would let me log in just fine but just trying to log in with the IP it was giving me an invalid username and password error.

    Without the name of the website my server could not resolve to the FTP request to the user's list for that website. So the FTP request to my server was still accepted, it was just accepted and resolved to the ISPConfig server itself instead of to the website I was trying to log into.

Share This Page