FTP problems: I can't connect

Discussion in 'Installation/Configuration' started by phileras, Oct 28, 2016.

  1. phileras

    phileras New Member

    Hi guys,

    I'm pretty new with ispconfig, but i'm amazed how nice developed is this control panel.

    I installed ispconfig in a linux vps, the installation process was smooth and easy, the only problem i have is when i try to connect through FTP, i'm using filezilla client, i tried several hosts, users and passwd. I created also 3 ftp accounts, and few users but none is working.
    I'm not sure if this is a problem of the ssl certificate or something related.

    Please can anyone giveme some ideas about how to fix this?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you use the ftp username incl. prefix as it is shown in the FTP user list? A prefix is added automatically to ensure that users of different clients don't collide.
  3. phileras

    phileras New Member

    Hi Till,
    Yeah, i tried with the prefix "default" + myser but im getting problems to connect, i tried to create different ftp accounts and users but im not sure why its not working. Maybe its a problem with the sftp or ftp protocol or config, im not really sure. Im thinking to do a clean reinstall.

    What do you suggest? do you need a capture of the ftp error?

    Best Regards,
  4. phileras

    phileras New Member

    Hi Again,
    As i see in my ftp client i connect and login correctly but it shows a timeout when trying to retrieve directory list:

    stado: Conexión establecida, esperando el mensaje de bienvenida...
    Estado: Inicializando TLS...
    Estado: Verificando certificado...
    Estado: TLS connection established.
    Estado: Logged in
    Estado: Recuperando el listado del directorio... // getting list of directory, files....
    Comando: PWD
    Respuesta: 257 "/" is your current location
    Comando: TYPE I
    Respuesta: 200 TYPE is now 8-bit binary
    Comando: PASV
    Respuesta: 227 Entering Passive Mode (XXXXXXXXXXXXXX)
    Comando: MLSD
    Error: Connection timed out after 20 seconds of inactivity
    Error: Error al recuperar el listado del directorio

    Why is this happening??
  5. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

  6. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Also, you mentioned SFTP, which is another option, generally more secure and less error prone - to use it, setup an SSH account (shell account), not FTP.
  7. phileras

    phileras New Member

    Thanks Jesse!! now its working.

    The thing is that seems that i cannot use a global (admin) ftp account to update every site i have on my vps, so im creating one ftp user for each site i have installed on ispconfig. I tried to set a upper level folder to have access from a single ftp account to all the websites but ispconfig says that its not possible. Any trick to fix this or a correct way to have an admin ftp account with access to all the folders??

  8. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    I don't know of any particularly clean way to do it.

    Each site is owned by a different user/group, and that's a good thing for security. So one option would be to abandon that security and run it all under one user/group, eg. say switch to using mod_php. I wouldn't recommend that, but it's an option.

    Another option would be to access all the files as a use, probably root, then fix up file ownership/permissions later. I imagine you can set 'PermitRootLogin without-password' in sshd_config, and set your SFTP (not FTP!) program to authenticate with a public key, and change anything you want on the system. Then maybe write a cronjob that runs through each website root folder and fixes ownership/permissions every hour? (Or even better, write a little app using inotify interface and trigger off actual changes/additions.) It's a bit of work, but would get what you're wanting done.

    What I tend to do is a mixture of A) setup an ssh account for each site, and use the same public ssh key to access them all, so I don't need to know any passwords (though I do have to lookup the correct usernames), and B) (the bad practice of?) working as root to put stuff in place in the backend, then remember to chown to the write user/group afterwords (prone to error, of course).

    There may well be another better option, but I'm not familiar with it offhand.
  9. jbonlinea

    jbonlinea Member

    I there,
    Oh I also wanted to have an kind of ftp super user but you convinced me not to go that way....
  10. peterpetr

    peterpetr Member

    I've spent many, many hours trying to get FileZilla to connect to my ISPconfig 3.1 Ubuntu 14.x server. I get the same errors as mentioned above:
    Command: AUTH TLS
    Response: 234 AUTH TLS OK.
    Status: Initializing TLS...
    Status: Verifying certificate...
    Status: TLS connection established.
    Command: USER myusername
    Response: 331 User myusername OK. Password required
    Command: PASS ****************
    Error: Connection timed out after 20 seconds of inactivity
    Error: Could not connect to server
    I added the passive port range in my firewall as described here:
    My server was setup using: The Perfect Server - Ubuntu 15.10 (nginx, MySQL, PHP, Postfix, BIND, Dovecot, Pure-FTPD and ISPConfig 3) @ https://www.howtoforge.com/tutorial/perfect-server-ubuntu-with-nginx-and-ispconfig-3/ (but my Ubuntu is 14.x). Websites, WordPress all work, but FTP is making me crazy. I would appreciate any insights or advice. Thank you.
  11. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    maybe filezilla isn't using passive mode? you might try sftp (ssh based protocol)

Share This Page