FTP_User table error

Discussion in 'General' started by diegoc, Aug 29, 2016.

  1. diegoc

    diegoc New Member

    Dear all,
    This is my first message on the forum. I'm Diego, I work as system engineer for a small Italian company.
    I'm writing this because I'm facing a strange issue with ISPCONFIG 3.
    I'm trying to manage an installation made up with 2 server: a webserver and a mailserver.
    I was able to create customers, sites, databases, mailboxes and everything I need, but when I tried to create an FTP User, I got a strange behaviour of the web interface. On the top of the FTP_Users page, there was a SQL error and I couldn't do anything on the page.
    Taking a look to the PHP code and the MYSQL table, I found that the query in the PHP code was trying to fetch the record of the FTP_User table and "order by" a field called USERNAME. Unfortunately there wasn't any field called USERNAME in the FTP_User table!!!
    I manually added the field to the table and the SQL error disappeared!! Then I tried to add an FTP user by clicking on the button, but the "FTP_USER_EDIT.php" didn't load :(:(
    Do you have any advice about this?
    Thank you in advance !!!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Download the ispconfig tar.gz of the version that you use on your server, there you find a file install/sql/ispconfig3.sql which contains the table definitions of an ispconfig system, search for the ftp_user table and ensure that the table on your system is exactly as the one defined there.

Share This Page