GeoIP not working? Possible bad database?

Discussion in 'HOWTO-Related Questions' started by lordshadow, Mar 16, 2009.

  1. lordshadow

    lordshadow New Member

    Hi, I setup GeoIP according to the howto given here:

    I have 2 issues which I'm assuming are connected;

    1. After creating the php file and restarting Apache2 I went to the test page with my cell phone only for the country to not come up?

    I get
    Country: N/A

    2. When trying to use it with the Horde webmail system, if I try to open a mail I get lots of php errors on the top of the page, which probably explains also why nothing is displayed on the weather plugin on the portal page either.

    I have tried downloading the latest database and replacing the old one with it only for still the same thing to happen.

    I am very puzzled by this and don't know if anyone's got any ideas on how to get it working properly??

    Many thanks

    It seems that I can't read the file as the text doesn't seem to be ASCII? Not sure if this is because it's a database file or something else but should this be the reason?
    Last edited: Mar 16, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in Apache's error log?
  3. lordshadow

    lordshadow New Member

    Thanks for the reply Falko.

    No there are no errors in the Apache error log to do at least with GeoIP.

    I had memory insufficient error which is sorted and a few other proxy errors, but that's only because I'm behind a reverse proxy with Squid.

    In the instance that it might be the account that I hadn't got as GeoIP.conf file needs a licence key and user ID, I opened a demo account at:

    and now have at least a temporary ID and licence.

    If I now run
    I get this error:

    # geoipupdate
    MD5 Digest of installed database is 757ef6d020a81dae0db2926c48f4a931
    Invalid product ID or subscription expired
    Could it be my product ID is wrong?

    It's currently set to 106!
  4. falko

    falko Super Moderator ISPConfig Developer

    I can't say anything about the license and the key, but your reverse proxy setup might cause problems. Read up about the X-Forwarded-For and REMOTE_ADDRESS headers (e.g. ).

    mod_geoip might simply see the wrong IP.

Share This Page