[hardy heron] freeradius-mysql-daloradius

Discussion in 'Installation/Configuration' started by kdclaver, Aug 12, 2009.

  1. kdclaver

    kdclaver New Member

    I'm trying to install freeradius and daloradius on ubuntu hardy following this howto (http://www.howtoforge.com/setting-u...ver-with-mysql-and-management-with-daloradius).
    After applying the different modifications on step3, I try to test via this command: freeradius -X. Then I encounter this error message (see below - More details are present in the attached files (radius-install for error message and radiusd.conf). Before continuing, the howto tell us to modify radius.conf, this file doesn't exist on my installation why I make modification directly in radiusd.conf.

    ============== error message ===========
    rlm_sql (sql): Driver rlm_sql_mysql (module rlm_sql_mysql) loaded and linked
    rlm_sql (sql): Attempting to connect to [email protected]:/radius
    rlm_sql (sql): starting 0
    rlm_sql (sql): Attempting to connect rlm_sql_mysql #0
    rlm_sql_mysql: Starting connect to MySQL server for #0
    rlm_sql_mysql: Couldn't connect socket to MySQL server [email protected]:radius
    rlm_sql_mysql: Mysql error 'Access denied for user 'root'@'localhost' (using password: YES)'
    rlm_sql (sql): Failed to connect DB handle #0
    rlm_sql (sql): starting 1
    rlm_sql (sql): starting 2
    rlm_sql (sql): starting 3
    rlm_sql (sql): starting 4
    rlm_sql (sql): Failed to connect to any SQL server.
    rlm_sql (sql): - generate_sql_clients
    rlm_sql (sql): Query: SELECT * FROM nas
    rlm_sql (sql): Ignoring unconnected handle 4..
    rlm_sql (sql): Ignoring unconnected handle 3..
    rlm_sql (sql): Ignoring unconnected handle 2..
    rlm_sql (sql): Ignoring unconnected handle 1..
    rlm_sql (sql): Ignoring unconnected handle 0..
    rlm_sql (sql): There are no DB handles to use! skipped 5, tried to connect 0
    rlm_sql (sql): generate_sql_clients() returned error
    rlm_sql (sql): Closing sqlsocket 4
    rlm_sql (sql): Closing sqlsocket 3
    rlm_sql (sql): Closing sqlsocket 2
    rlm_sql (sql): Closing sqlsocket 1
    rlm_sql (sql): Closing sqlsocket 0
    radiusd.conf[14]: sql: Module instantiation failed.
    radiusd.conf[1860] Unknown module "sql".
    radiusd.conf[1789] Failed to parse authorize section.
    ======= End of message =========

    I need your help to success this installation and follow up the rest of this howto.

    Regards !!!!

    Attached Files:

  2. kdclaver

    kdclaver New Member

    I have found the source of this error message, bad root's password in /etc/freeradius/sql.conf.
    I've changed it and now I can follow up.

    Thanks more for your care attention !!!!

    See you
  3. giovanny roman

    giovanny roman New Member

    Hello kdclave.
    I did your suggestion and it worked for me.

Share This Page