HELP 2.2.30 destroyed my machine

Discussion in 'General' started by kextra1, Mar 23, 2009.

  1. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    I upgraded to 2.2.30 from 2.2.29

    Webmail didnt work or admin panel or anything related to SSL.

    Co-Domains did not work that directed to ssl of course...

    such as a Co-Domain to

    So I downgraded to 2.2.29 and it completely wiped out my RECORDS!!!


    This is by far the WORST ISPConfig release of all time.

    I may get sued because of this...or even worse...have to switch to plesk

    When i go to a domain it has no info in ispconfig and does not even select my default server in the admin panel where the domain is shown.

    All domains go to the default: It works! default apache screen....I need to get this fixed asap if i am to stick with ispconfig.

    Please help!
    Last edited: Mar 23, 2009
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    How did you downgrade??? Just reinstalled 2.2.29 directly and reinstalled a DB-Backup?!
    Afaik there is no "official" downgrade I would say, destroying the data is more a problem of your way of downgrading.

    Why don't you restore the DB from the backup that the ispconfig 2.2.30 installation stored? Worked for me in the past without problems.
    Then upgrade to 2.2.30 again and do a further analysis, what the problem with those webmail problems etc. is.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Downgrading destroys your setup of course as you can not copy a database content with more columns into a database structure with less columns as Ben pointed out.

    Take a look at your /tmp directory if there are any .sql files which contain a backup of your database.
  4. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Installed sysdb.sql from backup zip

    I installed one of my older sysdb.sql backup files generated in a zip file within ispconfig and now everything shows up right again in ISPConfig.

    However, it's still not directing to the domain.

    All websites are directed to the default: "It Works!"

    Apache-default screen

    Please help
  5. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Possibly VHosts or httpdconf file?

    Is is possible my Vhosts or httpd.conf file's might have gotten screwed up?

    I can access the panel at:

    but i cant access any of the websites they go directly to apache2-default

    and none of the co-domain redirects work like which points to

    ...I am willing to pay someone for help.

    then im backing everything up.

    Name your price
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in your Vhosts_ispconfig.conf? Is it included at the end of your main Apache configuration?

    In my opinion it's the best. It contains lots of bugfixes and some new features.
  7. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    Downgrade fixed

    Well I ended up downgrading back to 2.2.29 and restored the sysdb for ispconfigdb.

    It may quite be the best. Maybe it's just my problem but it's most likely not just my problem. I was harsh with my frustrations...i do love ispconfig....but regardless ive run into trouble with this new version.

    How come all Co-Domains pointed to an ispconfig ssl site with :81, everytime when it's forwarded it omit's the ":81" and only goes to instead of or... instead of ...?
  8. falko

    falko Super Moderator ISPConfig Developer

  9. kextra1

    kextra1 ISPConfig Developer ISPConfig Developer

    You are the man Falko


    You are the man. I cannot tell you how much I thank you...

    I'm considering learning german so I can understand the variables... ;)

    I'd volunteer to do documentation u guys....but i dont understand german!....lemme know...and i'll write up code/variable documentation and help the project grow!



Share This Page