Help - Problem with logging in to Admin

Discussion in 'General' started by jsanglier, Aug 27, 2007.

  1. jsanglier

    jsanglier New Member


    I have suddenly encountered a login problem with my server. I typed in admin and my password and got:

    Warning: shell_exec() []: Unable to execute 'cat /home/admispconfig/ispconfig/adminmail.txt' in /home/admispconfig/ispconfig/lib/ on line 137

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/ in /home/admispconfig/ispconfig/web/login/trylogin.php on line 55

    The server seems to be working fine and I have not changed anything on it. I can bring up PhpMyAdmin fine, so the dedicated ispconfig server is working - but I can't login to the ispconfig user interface.


    All the best

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Did you change anything in the ISPConfig php.ini file?
    2) Post the ouput of:

    ls -la cat /home/admispconfig/ispconfig/adminmail.txt
  3. jsanglier

    jsanglier New Member


    Hi Till

    No, I never muck around under the hood with ISPConfig, I don't know enough ... but I have just issued that command and:

    ls: cat: No such file or directory
    -rw-r--r-- 1 admispconfig admispconfig 14 2007-08-27 21:56 /home/admispconfig/ispconfig/adminmail.txt

  4. mphayesuk

    mphayesuk Member HowtoForge Supporter


    I dont get a login error however I dont have that adminmail.txt file

  5. mlz

    mlz New Member

    How about:

    cat /home/admispconfig/ispconfig/adminmail.txt
  6. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    ls -la /home/admispconfig/ispconfig/adminmail.txt
    which cat
  7. jsanglier

    jsanglier New Member


    ls -la /home/admispconfig/ispconfig/adminmail.txt


    -rw-r--r-- 1 admispconfig admispconfig 14 2007-08-27 21:56 /home/admispconfig/ispconfig/adminmail.txt

    which cat



    and in answer to miz:

    cat /home/admispconfig/ispconfig/adminmail.txt


    [email protected]

  8. falko

    falko Super Moderator ISPConfig Developer

    Looks good. What's the output of
    ls -la /home/admispconfig
  9. jsanglier

    jsanglier New Member

    Hi Falko, here is the output:

    server2:~# ls -la /home/admispconfig

    total 24
    drwxr-xr-x 4 admispconfig admispconfig 4096 2007-07-24 00:28 .
    drwxr-xr-x 5 root root 4096 2007-07-24 00:23 ..
    -rwxr-xr-x 1 admispconfig admispconfig 24 2007-08-27 21:55 .forward
    drwxr-xr-x 8 admispconfig admispconfig 4096 2007-08-27 21:56 ispconfig
    drwxr-xr-x 2 admispconfig admispconfig 4096 2007-08-27 01:58 mailstats
    -rwxr-xr-x 1 admispconfig admispconfig 176 2007-08-27 21:55 .procmailrc

    This is all so strange since everything had been working fine for ages. So I don't know why it does not work now.

    Thanks for your help!
    Last edited: Aug 30, 2007
  10. falko

    falko Super Moderator ISPConfig Developer

    Looks fine as well.
    Just a shot in the dark: maybe your hard drive is full? What's the output of
    df -h
  11. jsanglier

    jsanglier New Member

    Hi Falko, no, it looks fine:

    (See next post - my connection crashed an I ended up posting twice. I am having one of those weeks!)
    Last edited: Aug 31, 2007
  12. jsanglier

    jsanglier New Member

    I only set up the server a couple of months ago and just use it for my own company websites:

    Filesystem            Size  Used Avail Use% Mounted on
    /dev/hda1             7.4G  2.0G  5.1G  28% /
    tmpfs                 189M     0  189M   0% /lib/init/rw
    udev                   10M   68K   10M   1% /dev
    tmpfs                 189M     0  189M   0% /dev/shm
    /dev/sda1             4.3G  137M  3.9G   4% /data1
    /dev/sda2             4.2G  137M  3.9G   4% /data2
    The actual installation is Debian Etch from your howto and ISPConfig - that's all. Apart from regualr apt-get upgrades and updating ISPConfig I have done nothing else with the back end. The front end sites are running Joomla that's the lot.

    THis is not some odd permissions problem, or perhaps the adminmail.txt is corrupted?

    If I run the command direct I get:

    server2:~# cat /home/admispconfig/ispconfig/adminmail.txt
    [email protected]:~#
    SHould it look like that, with "[email protected]:~#" all on one line?

    By the way. I have noticed that I get the same error come up if I log into webmail. THe webmail does display but the error is across the top of the page.

  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats fine as you executed it on the shell.

    Please delete the file:

    rm -f /home/admispconfig/ispconfig/adminmail.txt

    I'am nbot sure why you get this error message, but it should work fine without this file too, as the file in your installation just contained the default email address which is also used when the file is not present.
  14. jsanglier

    jsanglier New Member

    Hi Til, welcome to the mystery!

    Deleted the file and logged in. THis time I got in, but the page printed out hundreds of:
    Warning: popen(uptime,r) [function.popen]: Resource temporarily unavailable in /home/admispconfig/ispconfig/lib/plugins/check_uptime.plugin.php on line 54
    Warning: feof(): supplied argument is not a valid stream resource in /home/admispconfig/ispconfig/lib/plugins/check_uptime.plugin.php on line 55
    I had to kill the page to stop it.

    For the moment I have reinstated adminmail.txt, by the way

    Any ideas?
    Last edited: Aug 31, 2007
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    No, not really :(

    Please post the output of:

    grep admispconfig /etc/passwd
  16. jsanglier

    jsanglier New Member

    server2:~# grep admispconfig /etc/passwd
    admispconfig:x:1001:1001:Administrator ISPConfig:/home/admispconfig:/bin/bash
    I get the feeling something else is happening and these are symptoms

    Last edited: Sep 1, 2007
  17. jsanglier

    jsanglier New Member

    When I do an update of ISPConfig, what does NOT get replaced?

    When I discovered this problem a few days ago, the first thing I did was upgrade from 15 to 16. So I am thinking that what is causing the problem is not part of the update package.

    Just a thought.
  18. jsanglier

    jsanglier New Member

    It gets stranger

    First the good news: everything is up and running perfectly.

    Now the bad - I have no idea why.

    When this started I did do a reboot but that didn't help.

    However, I noticed that I suddenly could not collect emails from it. I suspect something that should have been running wasn't. So I tried another reboot - and everything is back up and running.

    Anyone have any educated guesses?

    Oh, and big thanks to Falko and Till for trying to work this out!


    (Old, knackered, musician dog, trying to learn new tricks!)

Share This Page