Help With VPS install

Discussion in 'ISPConfig 3 Priority Support' started by PJlarambla, May 10, 2014.

  1. PJlarambla

    PJlarambla New Member

    Hi All,

    Is there no where on this forum an Install script for installing on a VPS correctly. :confused:
    I have followed the Perfect server for Debian 7 twice now starting at page 3 because I have to load the template from my control panel on my VPS.

    I get the same problems each time I try to install: :(

    The script stops on the MYSQL server each time comes up with OK!When anything is loaded but is unable to start it so you get a FAILED message. it then seems to move on but then it keeps asking for the MYSQL root password from you every time you load anything and it is configering, you can enter this every time but it still asks for it.
    Then once you get to loading ISPCONFIG3 you answer the first block of questions then it comes up asking for the MYSQL password because it can not connect to the server. then we start going round in circles . Never getting near ispconfig install. :mad:

    At that point reboot the VPS and try to continual with the install and get no such file. It has taken me hours and still not getting any where.
    The problem is things are a bit out of date I think! even the manual 1.4 goes back to early 2013.

    Really looking for a good VPS install script, because all setups seem to be for a dedicated server. where the most popular now is VPSs I have 3 and they are bigger than most cheap servers.

    Hope this is in the right thread if not mod please move it.

    Many Thanks all. :D
  2. PJlarambla

    PJlarambla New Member

    Hi All,

    No one have any sort of answer for me. Have been looking on the web it seems I am not alone with this Question.

    There are a few sites with a so called answer with a script but they do not work either. :mad:

    Come on I am sure that many of you have a VPS with ISPConfig3 on them. How did you get it on there with out problems. :D

    Many thanks for reading.
  3. PJlarambla

    PJlarambla New Member

    Well I am very surprised that I have not had any help with this problem, from a Forum as good as what I have been told this one is! :(

    I would still be very grateful if some one could give some sort of help on how to overcome This problem, surely I am not the only one here that has this problem :confused:
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I moved your post to the priority support forum now. Please use that forum as howtoforge supporter t ensure that your post gets answered with priority as there are just too many posts to answer.

    The debian perfect server script is up to date, I use it daily to install servers for our customers all around the world. so there is nothing wrong with the guide.

    Which VPS do you use, how much ram does it has? A full setup as described in the perect setup guide needs at least 1GB RAM, better 2GB. If you have a vps with e.g. just 500MB ram, then not all services will be able to run at the same time.

    Regarding the error message: In which exact step of the perfect server dod you get the first error message and which exact error message do you get?
  5. PJlarambla

    PJlarambla New Member

    The VPS that I am trying to load ISPconfig3 on is an openVM it has 6 gig of ram and a 150gig of disk space.

    When the script is loading it is the Mysql that is giving the problems. it does not accept the password and just keeps asking for it, and near the end of the script it just goes round and round in circles.

    It has got to be a fualt in the printed scripts. There is some thing wrong, because I have tried about 5 times and the same fault keeps coming up, have tried on the following.

    On Debian, Ubuntu, and Centos. Tried them all. And followed the instruction on each of them to the Book. all have slightly different scripts. I am sure that you must use different scripts to what are printed.
    I have also just copied and paste and its the same.

    Bye the way thank you for your answer, though I thought I might have had an answer from the normal forum ????
    Last edited: May 14, 2014
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    We use the guides that are listed on this page:

    I and our other administrators use them daily to install serveers for clients by copy& paste, so they are known to work. If you used any of these guides then you can be 100% sure that the issue is not in the guides. These guides are used to setup more then 20 000 servers each month, so if they would be faulty, you would see a few hundred messages with installation failed here in the forum each day.

    That it did not work for you on many diferent setups just means that the ame error was made when following each guide. Thats not as uncommon as you might think, e.g. when the guide isntructed to use hostname localhost for a settinsg and you inserted each time the fqdn of the server and not localhost oryou inserted the IP address where a domain or hostname was requested.

    If mysql is not working on your server, then the ispconfig installer can not work as well. So you should test if mysql works like this:

    mysql -h localhost -u root -p

    and then type in the mysql root password that you had set.

    Btw. we offer also the exact result of some of the guides as virtualbox image, you can download it as subcriber to see yourself that the install script is correct and results in a working ispconfig setup.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    One thing that came to my mind is: Maybe you used the same mysql root password in all installs with some special chars that got interpreted by shell scripts, so that this causes the login to fail?
  8. PJlarambla

    PJlarambla New Member

    Hi Thanks for your reply,

    I agree maybe but only maybe! I have done some thing wrong.

    I did not put any bad figures, in the Mysql password just a strait forward simple name.
    It was only Mysql that was causing the problem all through the script it was stopping it and saying ( O.K.) but could not start so coming up ( Failed).

    I would like to know where on the forum that I may download the guides as virtual-box image, and what software I would need to view them. This time I will use a different VPS as well but it still has 5 gig of ram and 250 gig of disk space.

    Many Thanks for your help.
  9. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    So if mySQL fails to start up, what is the error in the syslog when this occurs?
    Without error messages its hard to guess what is wrong.
  10. PJlarambla

    PJlarambla New Member

    To be quite honest with you I do not know, because I tried to see if I could open Ispconfig3 because it went nearly to the end, where it was going round in circles and asking for Mysql password which I put in every time, maybe 6 or 7 times. so i just shut down putty by the X. then I reinstalled VPS each time.

    I did not know there was an error log or where it was.

    Thanks for your help.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The installer asks all qustions before it starts the installation. so when you skip the install at that stage, then nothing was installed at that time.

    To get this problem solved, we need a system that is installed until you get this problem. Otherwise we cant diagnose whats wrong with your server.
  12. PJlarambla

    PJlarambla New Member

    O.K. will do that but it will not be for a day or so because I am going to be a bit busy.

    I do as most do I can not answer the questions where the scripts are loading from the disk I move to where it starts with all the info and loading from SSH.

    This is because like most with a VPS you load from a control panel Templates.

Share This Page