How setup DNS/Mail Server in Centos 7 and Ubuntu

Discussion in 'Installation/Configuration' started by Ayog, Sep 23, 2015.

  1. Ayog

    Ayog New Member

    Hello all

    I want to know how to install and configure DNS/Mail Server in Ubuntu And Centos 7
    1. i want to setup dns so i can give nameserver to and domain registrar such as Name .com so i can use my home web server to live my website.
    Note:- i know the service called namecheap .com which directly redirect our website to ip but i want to create name server so i can use any of registrar

    2. i want to setup mail server from which i can use my domain name which i purchased from registrar as mail service

    (for example my domain name is demo .au so i want mail id such as user1@demo .au and i want if any body send mail to this address and i get mail and i check mail locally and also from any where like demo .au/webmail or something like that )

    i short i want hosting service of my own

    Thanks in Advance For help guys :) :);)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Ayog

    Ayog New Member

    ya i knew that.....just want to know how to do this in both thanks for hellp @till will see the both link will update if i need any help in those Tutorial :):):):):):):):):):):):):):):)
  4. Ayog

    Ayog New Member

    Hello @till after going thru all process according to tutorial for centos

    i am facing 2 error
    1. round cube service database error : connection failed ( Note : in test config during setup of roundcube there is one error = DSN (write) : NOT OK (SQLSTATE[28000] [1045] Access Denied for user 'roundcube@loaclhost using password: YES) , i tried to run installer again but "The Installer is disabled"

    2. no website runnning only blank page is coming even in info.php which working fine after setup of phpmyadmin when i checked.......i thing problem is coming after roundcube or ispconfig3 setup because when i tried to restart httpd service it show me i reboot the server and after that i having this problem , httpd default page is working fine but not others
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    1) The username that you used to configure roundcube is wrong. Check the roundcube setup again.
    2) Check the httpd error log to see which exact error you get.
  6. Ayog

    Ayog New Member

    1. after following these step i would successfully able too connect database
    http:// www. server-world. info/en/ note?os=CentOS_7&p=httpd&f=13 (Sorry For Space cant able to post link because i'm new bie and can't able to post link)
    however i not able to login any of the account.......tried all thing creating user changing password but don't know how to login or from where i should create mail address so i can login in it ( I remove the ispconfig3 because that is why httpd not working well after uninstalling isp and httpd....and reinstall httpd make web site running well with no problem )

    Can you please guide me up how to create mail address in web server so i can login it from round cube or how to make user which work with round cube.........because what i know i tried all none of is working.

    Thanks for helping :)
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to ispconfig, go to the email module and create a email domain, then create a mailbox by entering the amil address and password. Finally login to roundcube by using the COMPLETE email address and password.
    Ayog likes this.
  8. Ayog

    Ayog New Member

  9. florian030

    florian030 Well-Known Member HowtoForge Supporter

    CHeck you mail.log. Maybe amavis is not running due to a wrong hostname.
  10. Ayog

    Ayog New Member

    here the log i found nothing please have look still can't able get mail no problem in sending

    Attached Files:

  11. Ayog

    Ayog New Member

    when i created another email ID using ISPConfig3 and then try to mail on that email address i got this (unknown user: "username") msg with Undelivered Mail Returned to Sender email but when i send mail by loging to that email id mail going successfully.......but this (unknown user: "username") not coming on ayog@domain mail id because i thing my username is same...........guys did you got this why this happening
  12. Ayog

    Ayog New Member

    NO reply from Long Time @till
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    I'll answer question here if I have some free time. There is the priority support forum where all questions get answered with a high priority.

    The log shows that you send an email to "ayog at linkdemo dot co" which is an alias of the address "ayog at techbizsolution dot co dot in" and this address is handeld by an external server and postfix forwarded the email correctly to that external server.

    There is no failed email sending attempt in the log.

    is the domain of the email address that you send a email to listed somewhere in /etc/postfix/ or /etc/mailname or is it returned when you run the command "hostname -f" ?

    Btw. You send me a pm with a link to your forum post and you posted your complaint that I did not answer your post fast enough in my free time on my user board. That's spam!
    Ayog likes this.
  14. Ayog

    Ayog New Member

    i am sorry about that if you feel in such manner......and knew that you will reply if you get free time... i thought that may be due your expertise your much busy person and have so many notification that's why you are miss my post........really sorry for that

    and about mail..........when i try to mail on "ayog at linkdemo dot co" from "ayog at techbizsolution dot co dot its fail to deliver , there is no problem in sending mail....mail are going with no error , only i am facing error in receiving the mail , some time mail are going to var/spool/mail but not showing in roundcube mail client , 2. second error when i create new email thru ISPconfig3 example test at linkdemo dot co and send mail to this address , it giving me error of (unknown user: "username") so i have to make new user every time if i want to create new email address ??

    once again sorry for that i didn't mean that , just excited to knew what is going wrong and thought that you busy and not getting notification that why i PM you
  15. Ayog

    Ayog New Member

    Here is what i got when i run the command mail , here all mail which i got but its is not showing in roundcube. , last mail i try on 4.38 IST 29 OCT (Today) and that mail also in that /var/mail/ayog

  16. Ayog

    Ayog New Member

    ok i found the it is what i have done wrong.....i made the same host name as email domain name which is created by ISPconfig3 that why mail are going in /var/spool/mail/username and becoz that why also when i created new email account and sending mail to that email i am having that issue (unknown user: "username")

    and IF somebody have this issue in future please NOTE : do not get confused host-name always is different than domain name (website-name or domain-name)

    Thank you so much for help.....and sorry if i made in mistake which is not good for there staff and forum :) :) lovely help from you guys
    Last edited: Oct 29, 2015

Share This Page