How To Compile A Kernel - The SuSE Way- Errors

Discussion in 'Kernel Questions' started by LuisC-SM, Dec 26, 2006.

  1. LuisC-SM

    LuisC-SM New Member

    Hi Folks.

    First off I'd like to say I wish You all had a nice Christmas time along with your beloved friends and family.

    I have a Toshiba Satellite P105 SP921 which has a sound issue on SLED 10 and Ubuntu 6.10 (just works with acpi=off) and I've been trying to solve this since 10 days or so with no joy. However, during this long long research, I've found in some posts that using the latest prepatch kernel cuold solve some problems and that's what I've been trying to do.

    So I've followed this tutorial and when trying to apply the patch it's giving me some errors and asks me things, I don't really understand. I'm not exactly a noob in linux but also I'm not a programmer or coder, just use it because I really like it over any other platform.

    So, when I run "bzip2 -dc /usr/src/patch-2.6.20-rc2.bz2 | patch -p1 --dry-run" in /usr/src/linux, I get
    and then I don't know what to answer in this point so I just give it <Ctrl>+C to abort.

    I assume I followed everything as it's explained in the Howto. I'm using linux-2.6.19.tar.bz2 kernel and the patch-2.6.20-rc2.bz2 patch.

    Any ideas on what I'm doing wrong?

    Kind Regards

    Luis C. Suárez

    EDIT: Sorry but I missed the correct forum, so please admin, be so kind to move it to the right place in case it applies. TIA
    Last edited: Dec 26, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you apply another patch before you tried this one?
  3. Freibier

    Freibier New Member

    Hi, if found this thread because i had a similar problem :)
    I tried to patch kernel which obviously wasn't the right way.
    from concerning patches:
    They should be applied using the patch(1) utility to the source code of the previous full release with a 3-part version number (for example, the 2.6.12-rc4 prepatch should be applied to the 2.6.11 kernel sources, not, for example,
    LuisC-SM, maybe you applied the patch to 2.6.19 ?
    If so, you can do a "patch -R" with the to downgrade to 2.6.19.
    After that, the patch-2.6.20-rc2 applies smoothly.

Share This Page