HowTo: Apache2, PHP5 and SuPHP on Ubuntu 7

Discussion in 'Suggest HOWTO' started by HovardKr, May 30, 2007.

  1. HovardKr

    HovardKr New Member


    I have been trying for two days now to install a webserver with Apache2, PHP5 and SuPHP on a machine that runs Ubuntu 7 (desktop). But has not yet been able to make it work.

    The HowTo that I found on this site, telling how to install SuPHP with PHP4 and PHP5 would have worked just fine, but half way in the tutorial (I have been following it step by step) things are different than the text describes. Maybe there have been some updates since it was written?

    I very noob to this, so I hope someone could help me with a HowTo using the configuration mentioned above.

  2. falko

    falko Super Moderator ISPConfig Developer

    Where exactly did you encounter problems? What was different from the tutorial?
  3. HovardKr

    HovardKr New Member


    The first "error" was when I tried to run "apt-get install php4-cgi". There it gives a message that the file doesn´t exist.

    I just tried to continue anyway, and next "error" was when editing "suphp.conf" where it asks for "x-httpd-php=php:/usr/bin/php4-cgi" in the end...

    And the next is when adding the line to "httpd.conf" (at this stage this file is empty) and try to restart Apache I get an error messages... about here I give up, just because I am to new at this and don´t know how to "work around"...

    Is it ok to use "gedit" instead of "vi" in lines like this: "vi /etc/apache2/httpd.conf"??
  4. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure, but maybe there's no PHP4 for Ubuntu Feisty...

    If you're doing this from your Ubuntu desktop, then yes. gedit only works if you have a desktop installed.
  5. HovardKr

    HovardKr New Member

    I see. Well, then I guess that I am hoping that someone can help me (and maybe some others) out by making a Howto on getting SuPHP to run with only the versions thats in this threads title.


    Ok! Thanks!
  6. sjau

    sjau Local Meanie Moderator

    there is no php4 on ubuntu feisty... just use php5 then...
  7. HovardKr

    HovardKr New Member

    Yes, I was trying to do that... read the first post. I was hoping for a new HowTo on this one... :)

    Anyone who takes the challenge?

Share This Page