.htaccess never executed

Discussion in 'Server Operation' started by galmiche, Jun 4, 2006.

  1. galmiche

    galmiche New Member

    Dear All,

    I'm under Suse X64 and I try to enable the .htaccess file
    In my /etc/apache2/http.conf I have:

    # grant /srv/www access using .ht files
    <Directory /srv/www>
    Options None
    AllowOverride AuthConfig
    Order allow,deny
    Allow from all
    # use .htaccess files for overriding,
    AccessFileName .htaccess
    # and never show them
    <Files ~ "^\.ht">
    Order allow,deny
    Deny from all

    my main directory for the web server is /srv/www

    so under the sub dir "test" I added the file /srv/www/test/.htaccess

    AuthUserFile /srv/www/test/.htpasswd
    AuthName "Acces Restreint"
    AuthType Basic
    <limit GET POST>
    order deny,allow
    deny from .ipt.aol.com
    require valid-user

    But when I browse the repertory "test" no pop-up window appears asking me for a password, I see clearly the index.htm file as if no .htaccess file was existing.:confused:
    What parameters have to be actvated so apache2 takes .htaccess files into account?

    Many thanks for help,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you restarted apache after changing the httpd.conf?
  3. galmiche

    galmiche New Member

    Hey boy'z,

    I found the bug...
    As I am using a virtual server system, and even as I wrote in the main httpd.conf file:
    <Directory /srv/www>
    Options None
    AllowOverride AuthConfig

    thus I have had in the directives inside my virtual .conf menu another line
    <Directory /srv/www/my_server>
    Options None
    AllowOverride None

    Then this one, specially for the sub-dir my_server, overlapped the previous AllowOverride value !

    So, to all of you, thanks for help and double check overlapping values :)


    Now..I have to write correctly my .htpasswd file...a good job to do !
    Last edited: Jun 4, 2006

Share This Page