http error 500 when trying to access admin [SOLVED]

Discussion in 'Installation/Configuration' started by retroqwe, Apr 20, 2017.

  1. retroqwe

    retroqwe New Member

    tired to log into the admin section on port 8080 and i get a certificate warning then goes to a error 500 page.
    updated ispconfig to 3.1.2 running 14.04 ubuntu. all sites are working just not the admin, i have removed all php7 just in case this was an issue.
    password in : /usr/local/ispconfig/server/lib/ works fine in phpmyadmin
    and have reinstalled mysqli: apt-get install --reinstall php5.6-mysql
    have i missed something?

    the error on apache2 error log is
    [fcgid:warn] [pid 2319] [client] mod_fcgid: stderr: PHP Fatal error: Class 'mysqli' not found in /usr/local/ispconfig/interface/lib/classes/ on line 31

    php -v
    PHP (cli)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

    root@linux:/var/log/apache2# php -r 'phpinfo();' | grep -i mysqli
    MysqlI Support => enabled
    mysqli.allow_local_infile => On => On
    mysqli.allow_persistent => On => On
    mysqli.default_host => no value => no value
    mysqli.default_port => 3306 => 3306
    mysqli.default_pw => no value => no value
    mysqli.default_socket => no value => no value
    mysqli.default_user => no value => no value
    mysqli.max_links => Unlimited => Unlimited
    mysqli.max_persistent => Unlimited => Unlimited
    mysqli.reconnect => Off => Off
    mysqli.rollback_on_cached_plink => Off => Off
    API Extensions => mysql,mysqli,pdo_mysql
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    so php cli has mysqli, but cgi mode does not? do you have the normal system php version installed? (did you replace the system php with version 7, then tried to revert?) Maybe check that mysqli is enabled in cgi config, eg. in debian:

    # cat /etc/php5/cgi/conf.d/20-mysqli.ini
    ; configuration for php MySQL module
    ; priority=20
  3. retroqwe

    retroqwe New Member

    yes i did install php7 and it was working fine for the last few month, it stopped [admin logon] a few days back after an apt-get update / upgrade [i think]

    results of cat /etc/php5/cgi/conf.d/20-mysqli.ini
    ; configuration for php MySQL module
    ; priority=20
  4. retroqwe

    retroqwe New Member

    i fixed the problem seems like a few of the apache modules had been removed. ran

    apt-get install apache2 apache2-suexec libapache2-mod-fcgid php5-cgi

    and all is good now
    till likes this.

Share This Page