Discussion in 'General' started by Hans, Mar 14, 2006.

  1. Hans

    Hans Moderator Moderator

    When i login in ISPConfig at everything looks normal.
    When i click on > Management > Settings, i have to login again.
    At this new login-screen the address in my browsers shows:

    Yes, 5x w! I do not understand!

    After login to verify the settings in > Management > Settings, the wwwww, are still there.

    So, i tried the following:
    In my browser i went to the URL:, which works fine. But ... Also works and also !

    It does not matter how many w's i put there, i can reach my domain.

    This looks very strange to me and i have to say that this appears since i have ISPConfig 2.2.0.

    What could be wrong?

    Please let me know!

    Last edited: Mar 14, 2006
  2. edge

    edge Active Member Moderator

    Looks like a DNS setting to me.
    Does also work?

    If so, you have in the cname an Alias '@' pointing to your IP (I think) in the DNS setup.
  3. Hans

    Hans Moderator Moderator

    Yes, works too.
    And you are right about the cname pointing to my IP.
    But is this the reason? I did not notice it before...
  4. edge

    edge Active Member Moderator

  5. falko

    falko Super Moderator Howtoforge Staff

    What does the URL part in /home/admispconfig/ispconfig/lib/ look like?
  6. Hans

    Hans Moderator Moderator

    The URL settings within this file look like this:

    * System Settings

    $go_info["server"]["dir_trenner"] = "/";
    $go_info["server"]["server_root"] = "/home/admispconfig/ispconfig";
    if(isset($_SERVER['SERVER_NAME']) && isset($_SERVER['SERVER_PORT'])){
    $go_info["server"]["server_url"] = 'http://'.$_SERVER['SERVER_NAME'].':'.$_SERVER['SERVER_PORT'];
    } else {
    $go_info["server"]["server_url"] = "";
  7. falko

    falko Super Moderator Howtoforge Staff


    if(isset($_SERVER['SERVER_NAME']) && isset($_SERVER['SERVER_PORT'])){
    $go_info["server"]["server_url"] = 'http://'.$_SERVER['SERVER_NAME'].':'.$_SERVER['SERVER_PORT'];
    } else {
    $go_info["server"]["server_url"] = "";
    with just

    $go_info["server"]["server_url"] = "";
  8. Hans

    Hans Moderator Moderator

    This works Falko! Problem solved!

Share This Page