httpd error bad user name

Discussion in 'ISPConfig 3 Priority Support' started by edworcs, Mar 8, 2016.

  1. edworcs

    edworcs New Member

    This is a master ISPConfig server ( on CentOS release 6.7 (Final).
    When I try to add a new site I get a vhost.err file created in /etc/httpd/conf/sites-available/
    This is a single client machine. When I look at /var/www/clients/client1 I see both a user name directory and a symlink are created:
    drwxr-xr-x 9 root root 4.0K Mar 8 13:49 web841
    lrwxrwxrwx 1 root root 32 Mar 8 13:49 -> /var/www/clients/client1/web841/
    There are, however, some orphan directories in /var/www/clients/client1 with no symlinks (might be helpful in diagnosing the problem).
    I've tried Tools > Resync > Resync Websites with no improvements.
    It looks like the users system has gone out of sync hence the error. Any tips for how to go about solving this would be greatly appreciated.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    A vhost file with .err ending means that ispconfig created this file as new vhost file, then it tried to restart apache but the apache restart failed, therefor ispconfig saved the file with .err ending and restored the last working config for that file.

    The reason can be e.g. a line in the apache directives field of that website which apache does not understand. The best way to diagnose the underlaying issue to make a backup of the current .vhost file of that site, rename the .vhost.err to .vhost and try to restart apache and then check which error you get on the shell and / or in the apache error.log.
  3. edworcs

    edworcs New Member

    Thanks for the quick reply.
    I got to the point you describe before I wrote the initial message. I apologise for not being clearer.
    None of the sites on the server has an entry in the apache_directives field of the web_domain table. This is a DNS and forwarding server. All of the sites are set up with redirects to other, live websites.
    service httpd restart gives this error (the user name changes):

    Starting httpd: httpd: bad user name web841

    This error is output to screen. /var/log/httpd/error_log has no errors.
    /var/log/ispconfig/httpd/ is empty.

    Any help you can provide would be gratefully received.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Each website in ISPConfig has its own Linux user and these users seem to be missing now on your server and therefor httpd complains as it cant start without the users of the website. Does the user web841 exists in /etc/passwd?
  5. edworcs

    edworcs New Member

    Hmm. This is very strange. /etc/passwd has a last user of web821. Web 825 seems to have the right listing in /var/www/clients/client1

    drwxr-xr-x 9 root root 4.0K Jan 1 16:47 web825
    lrwxrwxrwx 1 root root 32 Jan 1 16:47 -> /var/www/clients/client1/web825/

    which means that web822, web823, web824 and so on are missing from /etc/passwd. This must mean that ISPConfig is unable to add these new users... Where should I look to figure this out?
  6. edworcs

    edworcs New Member

    I think I've got it.
    I turned on DEBUG. I edited the crontab to switch off /usr/local/ispconfig/server/ nd ran it from the command line.
    I got this:
    Multiple entries named 'sshusers' in /etc/group. Please fix this with pwck or grpck.
    useradd: failed to prepare the new /etc/group entry 'sshusers'​
    There were two groups for sshusers in /etc/group. I deleted one.
    pwck needed 800+ entries in /etc/shadow !!
    I've just added a new site and it seems to have worked. Thanks for your help with this!

Share This Page