Https not working

Discussion in 'Installation/Configuration' started by leen, Oct 21, 2006.

  1. leen

    leen New Member

    I have been running ispconfig for a while now no problems.

    Yesterday I installed typo3 and had some problems with php.ini, but I figured it out. During these problems I restarted the server and one time the whole computer.

    Today I wanted to go to the admin panel and I got error: can't connect to sever

    I am running FC4
    netstat -tap gave :
    tcp 0 0 *:https *:* LISTEN 3382/httpd

    I am completely stuck.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    /etc/init.d/ispconfig_server start
  3. leen

    leen New Member

    This is what I get.

    ispconfig_httpd: could not open document config file /root/ispconfig/httpd/conf/httpd.conf
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    FreshClam is already running!
    ISPConfig system is now up and running!

    locate httpd.conf gave :

  4. falko

    falko Super Moderator Howtoforge Staff

    Did you accidentally rename that file? Anyway, rename it back to httpd.conf:

    mv /root/ispconfig/httpd/conf/httpd.conf,v /root/ispconfig/httpd/conf/httpd.conf
    and restart ISPConfig:

    /etc/init.d/ispconfig_server restart
  5. leen

    leen New Member

    I did as you told but stil not working.

    /etc/init.d/ispconfig_server restart
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    Syntax error on line 1264 of /root/ispconfig/httpd/conf/httpd.conf:
    Invalid command '@', perhaps mis-spelled or defined by a module not included in the server configuration
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    ISPConfig system is now up and running!

    The first part of the httpd.cof looks like this:
    head 1.1;
    locks; strict;
    comment @# @;

    date 2006.; author root; state Exp;
    next ;


    @Initial revision
    ## httpd.conf -- Apache HTTP server configuration file
  6. leen

    leen New Member

  7. falko

    falko Super Moderator Howtoforge Staff

    You can delete the other one as it doesn't contain any Apache directives at all. You must have replaced the contents somehow...
  8. Nap

    Nap Member

    Not sure if you've fixed it, but your NETSTAT -TAP report is showing that your Apache is listening on port 443.
    I think you should have a line that ends in /ispconfig_http (probably on port 81) for the ISPConifg server.

  9. leen

    leen New Member

    I thought I fixed it but today again it didn't work.
    Something is changing the httpd.conf file.

    I just coppied the httpd.conf_https back to httpd.conf and all is working again.
  10. mopi1402

    mopi1402 New Member

Share This Page