I can not enter to websites and use mail

Discussion in 'Installation/Configuration' started by azuritetechs, Aug 30, 2023.

  1. azuritetechs

    azuritetechs Member

    First of all thank you for your help and attention.

    I do not why I can not enter to websites and receive or send mails using Thunderbird (Webmail works fine) from a computer connected to the same local network than the server (Ubuntu server 18.04 with PHP 5.6, PHP 7.0, PHP 7.1, PHP 7.3 and PHP 7.4) in which is installed ISPConfig. Maybe I have some bad configuration in ISPConfig?

    I attached the HTF report because I exedeed the maximum amount of characters.

    Thank you!

    Attached Files:

    Last edited: Aug 30, 2023
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a new installation, or did that work before? As you are using an old Ubuntu version, you have been using the system probably for several years?
  3. azuritetechs

    azuritetechs Member

    Yes, is an old installation. I am using ISPConfig 3.2.6 and in the past worked. Another thing that I want ask if I can pdate to 22.04 safely without break ISPConfig current installation.
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I believe ISPConfig 3.2.6 does not support Ubuntu 22.04, so you can't.
    You should first update ISPConfig, then ubuntu to 20.04 and then to 22.04. Search for update threads in this forum, there should be several. Update ISPconfig following ISPConfig update instructions, update Ubuntu following Ubuntu update instructions.
    To your original question: htf-report shows you have mismatched versions of PHP for cli and cgi. I would say this causes problems.
    You wrote can not connect from same subnet. Does it works from public internet? If this is a multi homed host, are the services listening on only one interface?
  5. azuritetechs

    azuritetechs Member

    Ok, understood I will try to update Ubunti using this method once I resolved the original problem. Thank you Taleman.
    Regarding the original topic:
    • Recently we changed the public IP and I changed the IP in the ISPConfig portal and in the DNS records. Maybe the problem of the mail is related to the DNS record in the domian provider portal? I can share screenshots of this if is needed. We changed the public IP before and I did the same process and worked well. I discussed this problem with the team and it looks like during the lockdown at the pandemic situation (the most of part of us we was not working in the office) some people that in some point visited the office had the same problem even with the old public IP.
    • How i can fix the problem with the versions of PHP for cli and cgi?
    • I can enter to the websites using a computer outside the local network and the webmail works entering from the local network or outside the network but not. In fact a can not enter to ISPConfig using the public IP and public port only works using the local IP of the server and the port 8080.
    • This case is not a multi homed host as far I know. The optic fiber is connected to the ONT, the router (this router is connected in bridge mode to transfer the data to our custom router) of the ISP company is connected to the ONT, our custom router is connected to the ISP company router and the server connected to our router.
    • For the other hand, I checked that I can not connect to the folder sites using Filezilla. But I think that is another problem.
    Thank you
    Last edited: Aug 30, 2023
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If ISPConfig worked before and you have not changed ISPConfig, but you changed your network setup, then your issue is likely related to your new network setup and not to ISPConfig. You might want to contact the support of your router to ask them how to set up things properly so that you can connect to a Linux server from outside and from within your network. E.g. ISPConfig itself listens on all IP addresses of your system on port 8080, it does not matter for ISPConfig if you connect from inside or outside your network. So if one of these connections fails, then this is blocked by your router and not ISPConfig.

    For the websites, I recommend that you use * in the IPv4 field of each website and not an IP address to ensure that websites are accessible on any IP that you might have assigned to the server.
  7. azuritetechs

    azuritetechs Member

    Hello Till,
    Thank you for your comment. As I said I talked with my team and since the 2021 looks like does not works (access to website locally and receive and send mails locally) and I detected this error now because we changed the office and I tested this from the office and does not work.

    Regarding IPv4 field, I have the * in all the websites. I think that the problem is in ISPconfig but I am not sure. How I can check this?
    In IP address field in System/Server Config I put the new public IP and the IP address field in System/Server IP address i put the local IP of the server. But to be honest I do not know if is a IP related problem. I need your help.

    Thank you!
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    My guess is this does not work. It must be the public IP address.
    I tried reading ISPConfig manual, but it is not clear what these two places mean.
  9. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    From what I gathered, I think this could be mostly due to your change of office, thus might be related to your ISP provided IP and router setup / settings.

    You should check whether that new office IP is fixed or dynamic, whether your ISP open its port 25 (because mail service is probably not working properly because of it), whether your ISP router and your custom router are setup properly or have proper settings.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Good, so the websites are accessible from internal and external IP in regard to web server settings.

    This is really unlikely, as ISPConfig vhost and also websites when using * are accessible from any IP that connects to your server. ISPConfig is not even capable of disallowing access depending on external or internal access. As I mentioned above and as mentioned by @ahrasis , the most likely reason for your issue is your router and network setup.
  11. azuritetechs

    azuritetechs Member

    Thank you @ahrasis and @till. I will try to call the technical service of th ISP and the creator fo the router. To see what I can achieve. I will update you as soon as possible.
    Thank you!
  12. azuritetechs

    azuritetechs Member

    I contacted with the ISP and the creator of the router and all the configuration is fine. For some reason ISPconfig cannot resolve locally the domains of the websites that is managing.

    Thank you
  13. pyte

    pyte Well-Known Member HowtoForge Supporter

    A detailed description of the network setup would be usefull. Do you have multiple public IPs/your own subnet? Do you have a single public IP? Is Port based NAT in use?

    Am i missing something? In this whole thread i could not figure out how traffic flows or is suppose to flow. This information is crucial for the debugging.

    Did you try to scan the public ip adresse/adresses with a port scanner like nmap and see if they are connectable?
    ahrasis likes this.
  14. azuritetechs

    azuritetechs Member

    Hello pyte,
    • This is the network setup: GPON ONT (ISP) -> ISP router (bridge mode) -> Switch -> My router -> Server 1 and 2.
    • I have a static public IP.
    • I have several open ports in my router to the local IP of the server 1 and 2.
    Please feel fre to ask me about more ingormation if you need.

    Thank you
  15. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    I don't see you are providing enough information in this thread for us to help you properly.

    All I can guess with the latest information above is your ISP router is not opening or forwarding relevant ports to your internal router before that internal router can pass that to the servers.

    Other than that I think you are still holding the necessary details and therefore, for now, if the above guess is wrong, I think the best is getting professional help from ISPConfig, which will be done in private and confidential, instead of sharing it publicly.
  16. azuritetechs

    azuritetechs Member

    Hello Ahrasis,
    Thank you for you message. What information do you need? I will try to give you all the information, please be clear.

    I think that the problem is not caused by the ISP router because in the past we had not the ISP router (only our router) and we had the same problem.

    How I can request the professional help from ISPConfig?

    Thank you
    Last edited: Oct 27, 2023
  17. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  18. azuritetechs

    azuritetechs Member

    Thank you Taleman!

Share This Page