I can only seem to get as far as getting a site index page....

Discussion in 'Installation/Configuration' started by rollerskate, Sep 16, 2018.

  1. rollerskate

    rollerskate New Member

    I am using Ubuntu 18.04 (cloud instance). First, I tried the auto-installer script from ISPConfig's documentation page for Ubuntu 16.04. The connection gets refused. When I tried the instructions for manual installation for Ubuntu 18.04 specifically, I don't even get a simple web server. There is nothing answering to even refuse the connection at my server's IP address at all, 500. Now, this is where it gets interesting. If I follow the instructions for Ubuntu 18.04, and then follow up with the auto-installer, I CAN get at LEAST a site index at my server's IP. E.G., a list of all the files in my /var/www/html folder. But if I attempt to open any actual URLs, like ./install/install.php, I get this:

    -------------------------------------------------------------------------------- _____ ___________ _____ __ _ ____ |_ _/ ___| ___ \ / __ \ / _(_) /__ \ | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ / | | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ | _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \ \___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/ __/ | |___/ -------------------------------------------------------------------------------- >> Initial configuration Operating System: Ubuntu 18.04.1 LTS (Bionic Beaver) Following will be a few questions for primary configuration so be careful. Default values are in [brackets] and can be accepted with . Tap in "quit" (without the quotes) to stop the installer. ERROR: Cannot write to the /var/log directory. Are you root or sudo ?

    This error has got me baffled because I don't know what file is trying to write to the /var/log directory, so I have no idea what I should be changing the permissions for.

    This is for ISPConfig 3.x.
    Last edited: Sep 16, 2018
  2. rollerskate

    rollerskate New Member

    Please. Someone help me. I'm all out of ideas now.

    I set up a new cloud instance.
    I stripped down to barebones tactics and simply set up a LAMP server with SSL first, following DigitalOcean's instructions, to ensure smoothest possible sailing....

    I made sure Apache and PHP were working before proceeding...
    I used the manual installation guide found at
    h**ps://w*w.howtoforge.com/tutorial/perfect-server-ubuntu-18.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/. No errors about the spam filtering this time, but I don't think that's really affecting anyway.

    Next, I downloaded the ISPConfig installation from

    I extracted the archive to my /var/www/html directory.
    I still get a 500 error when I try to go to h**ps://myserver.com:8080....
    When I try to go to h**ps://myserver.com/install/install.php, I get

    System: Ubuntu 18.04.1 LTS (Bionic Beaver) Following will be a few questions for primary configuration so be careful. Default values are in [brackets] and can be accepted with . Tap in "quit" (without the quotes) to stop the installer. ERROR: Cannot write to the /var/log directory. Are you root or sudo ?

    It's a plain text file, so it's not like I can respond to it. It's the only file I can bring up out of any of the PHP files I've tried from the ISPConfig directory.

    Testing PHP works fine. Testing Apache works fine. I don't understand how the ISPConfig directory is supposed to work in the /var/www/html directory when it doesn't have any index.php file in it. Of course I get an error 500, there's no index file in the html directory.......

    If there is some kind of script I need to run to GET an index file, please do clue me in.....
    If there is some way I am supposed to run that mysterious install/install.php file, please do clue me in.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You used 4 guides for your installation, 3 of them are not for ISPConfig so using them will likely make your server fail when using them. The only guide, which cóntains the complete setup of all required components, that you should have used is this one: https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/

    I recommend that you delete the droplet, create a new one with a minimal Ubuntu 18.04 as basis and then follow only the one official guide that I liked above.
  4. rollerskate

    rollerskate New Member

    First of all, thank you so much for responding!
    I don't know if you noticed, but that is exactly what I described doing in my second post.
    The problem is that the tutorial cuts off at the actual installation of ISPConfig.....
    So even with the server set up using that guide, I'm stuck at installing ISPConfig, because there's no instructions for it....
  5. rollerskate

    rollerskate New Member

    I've also repeated this same issue on several other different distros using different "ultimate guides" from this website/ISPConfig. None of them included instructions on how to install ISPConfig. I'm pretty sure the issue is not my server setup, but the fact that I'm simply not installing ISPConfig, and don't know how to do anything but extract the folder to the appropriate public html access directory. What happens after that? I haven't the faintest clue. There's no index.php, readme.txt, make/configure files, or anything else in the ISPConfig directory to give me even the slightest clue. Can't find any instructions online either. Just how to set up the server FOR the installation. Not how to actually INSTALL.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorial describes in detail the ispconfig installation incl. how to download it and what to answer in each step of the installer, so you can not have read it until the end when you claim that it's not described in the tutorial. Amd it's described in all tutorials, so you can not have read all pages from any of them. The tutorial has 3 pages:


    Start with the first page and then do all staps as described on all 3 pages.
    rollerskate likes this.
  7. rollerskate

    rollerskate New Member

    Okay, thank you. When I click "next" on the first page, for some odd reason it just takes me back to the main site's page. Now I know there are more pages to this tutorial. Thank you for linking them, as well!

Share This Page