ImageMagick supported formats no value

Discussion in 'Installation/Configuration' started by Endre Utchay, Nov 1, 2020.

  1. Endre Utchay

    Endre Utchay New Member

    I got the below error in wordpress debug log:
    PHP Fatal error: Uncaught ImagickException: NoDecodeDelegateForThisImageFormat `JPEG' @ error/constitute.c/ReadImage/560
    I have checked phpinfo and found this:
    imagick module enabled
    imagick module version 3.4.4
    imagick classes Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
    Imagick compiled with ImageMagick version ImageMagick 6.9.10-23 Q16 x86_64 20190101
    Imagick using ImageMagick library version ImageMagick 6.9.10-23 Q16 x86_64 20190101
    ImageMagick copyright © 1999-2019 ImageMagick Studio LLC
    ImageMagick release date 20190101
    ImageMagick number of supported formats: 0
    ImageMagick supported formats no value
    I am running Debian 10 (Buster), ISPConfig 3.2, PHP 7.4 set up using "The Perfect Server - Debian 10 (Buster) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1"
    I have already found that using jailkit was a very bad idea as it messed up database and timezone configurations.
    I have found this thread which helped me a lot: "PHP support for Jailkit user - Discussion in 'ISPConfig 3 Priority Support' started by pawan, Dec 12, 2017."
    But now I am stuck as I do not know how to get imagick to work.
    I am worried what other hidden errors can there be on my server :(
    Please help me.
    Thank you!
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    PHP 7.4 is not a supported version on Debian 10 (supported by ISPConfig, that is).
  3. Endre Utchay

    Endre Utchay New Member

    Yes, I have seen you warned users about this before.
    I wanted to use PHP 7.4 as an alternative PHP version for wordpress site.
    Too bad I was very tried and frustrated after I ran into multiple problems, have fixed the ones making the wordpress site unusable and them came this one with imagemagic. I googled to find a solution and have followed some advice to reinstall imagick and imagemagick and while doing so I mistakenly upgraded Debian core PHP 7.3 to 7.4 :(
    Surprisingly everything else seems to work, but the original problem still exists.
    I do not have the spirit to start reinstalling the whole system now.
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    sudo update-alternatives --config php
    and select PHP 7.3 so that is used for the CLI again.

    For your original problem, I'm not familiar with Imagick, but when searching online I found several threads about this, so you might want to read those and see if you find a solution.
    Endre Utchay likes this.
  5. Endre Utchay

    Endre Utchay New Member

    Thank you very much for this nice and simple solution!
    Th0m likes this.
  6. Endre Utchay

    Endre Utchay New Member

    The error was caused by the chrooted PHP process was unable to reach ImageMagick.
    Setting this in jk_init and adding "php" to Jailkit chroot app sections in ispconfig solved the problem for me:
    comment = default php version and libraries
    paths = /usr/bin/php, /usr/lib/php/, /usr/share/php/, /usr/share/zoneinfo/, /usr/lib/x86_64-linux-gnu/ImageMagick*, /usr/share/ImageMagick*, /etc/ImageMagick*
    includesections = php_common, php7_3, php7_4, env

Share This Page