initial admin login incorrect

Discussion in 'General' started by mgburr, Jul 31, 2005.

  1. mgburr

    mgburr New Member

    I installed ISPconfig and finally worked some issues around on Slackware 10.1. Had to trick the installer to make it think it was mandrake 8.1. After installing and checking the original web pages they were o.k. Went to port :81 and got the login page. I tried the initial admin:admin login and keep getting an error with the username. I restarted ispconfig and the mysql d-base server. both start without errors. What I would like to know is there a .htpaccess or .htpasswrd file that can correct that issue or do I need to re-create the mysql dbase file and re-install the system?.

  2. falko

    falko Super Moderator Howtoforge Staff

    Can you check if the ISPConfig database has been created and if it contains tables? My guess is that your database is empty...
  3. mgburr

    mgburr New Member

    I manually created a database. It has no entries. is there a listing of what tables etc that needs to be created. or a "dummy" database that I can copy/import??
  4. Tribal-Dolphin

    Tribal-Dolphin New Member

    The file db_ispconfig.sql is on the root directory of the ISPConfig archive.
    The installer normally delete this dir after install.
    Untar again the archive and dump the file to our mysql database.
  5. falko

    falko Super Moderator Howtoforge Staff

    But that won't help because in the SQL dump the table isp_server is empty. It is filled by the installer on the fly. There should only be one entry in isp_server, like this:

  6. mgburr

    mgburr New Member

    O.k. I was able to get the tables re-created. after manually creating the isp_server database I did the mysql -uroot -p***** < db_ispsconfig.sql isp_server. That created all the necessary tables. re-started the apache server and the mysql server. Still back at square 1. Found the user admin in the isp_server/sys_user table, viewed the data, then deleted the pasword. restarted the mysqld and still can't verify the user with a null password. i'm using the http vice https access, and operating from the local machine.

  7. falko

    falko Super Moderator Howtoforge Staff

    Try to put the md5 string of a password into sys_user instead of a null password.
  8. mgburr

    mgburr New Member

    Still not working. used echo test | md5sum and returned a valid md5hash for the word test. dropped that into the user file for admin and it still doesn't recognize either the password or the user. Almost like the script won't allow the validation of the user with the user database

  9. falko

    falko Super Moderator Howtoforge Staff

    Does ISPConfig connect to the right database? Please check that in /home/admispconfig/ispconfig/lib/
  10. mgburr

    mgburr New Member

    took me a few to figure it out. was an issue with the database, and also the user that was allowed to access the mysql service. fixed both of those and now it works. Now you can say it works on a Slackware installation. Although it took some tweaking.

  11. reason8

    reason8 Member

    Login problems

    Hello and good day.
    I just installed ISPConfig on OpenSUSE 11.0 with all components per the installation page. I am having a problem logging into the admin page. It is not taking the login credentials of "username: admin and password:admin".
    I have noticed that when I boot my server, I received a warning stating:
    Warning: mysql_fetch_aray(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/ on line 47
    No results found! ISPConfig system is not up and running!"

    What could be the problem? I chose SSL for login and have added the https:// to access the site.


  12. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not correctly installed on your system, please run:


    to delete it.

    Before you install it again, make sure that:

    1) No database with the same name exists already that you choose for ispconfig. The installer will create the database itself.
    2) That you use the mysql user "rot" to install ispconfig.
    3) That the mysql password does not contain any special chars.
  13. reason8

    reason8 Member

    The problem was that I created a mysql pw using the non a-z and A-Z convention. I was trying to create a strong password. I changed the pw in mysql and was able to get past the admin login but received an error of indicating the file had errors in them.

    Now I am trying to uninstall and it is giving me this error:

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/ on line 47
    No results found!

    I have reinstalled and reconfigured this multiple times already but am willing to give it another shot but how can I uninstall and reinstall with out wiping th e OS if it wont uninstall? Thanks for the help!
  14. till

    till Super Moderator Staff Member ISPConfig Developer


    /etc/init.d/ispconfig_server stop
    rm -rf /root/ispconfig
    rm -rf /home/admispconfig

    then delete the directory that is named like the ispconfig mysql database in /var/lib/mysql/
  15. reason8

    reason8 Member

    I removed the directories but when ispconfig install asks me mysql password, its not allowing me to login. I think it is still remembering the old password. Obviously all of mysql was not removed when I deleted /var/lib/mysql.

    I even tried to change the sql password in another login and its not accepting that either.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    You should only remove the ispconfig database from /var/lib/mysql/, nothing more and this has nothing to do with the mysql password.

    You can set a new mysql password e.g. with the mysqladmin command.
  17. reason8

    reason8 Member

    That is the only db that I removed. Changing the sql pw did not work. So I wiped everything clean and restarting. Thanks.

Share This Page