Install Horde 5 Webmail For ISPConfig On Debian Wheezy Through PEAR

Discussion in 'HOWTO-Related Questions' started by Xcantion, Jul 19, 2014.

  1. Xcantion

    Xcantion New Member

    Hello everybody..

    i have used this howto.. everything seem to work fine .. but i cant get horde to work ...
    I want to use horde with NGINX..

    Horde is Installed in /var/www/horde.. and i want to use horde like this way "" or via

    i have tried a lot of ways but i became only 404 error...
    My last Try:

            location /horde {
                   root /var/www/;
                   index index.php index.html index.htm;
                   location ~ ^/horde/(.+\.php)$ {
                           try_files $uri =404;
                           root /var/www/;
                           fastcgi_pass unix:/var/run/php5-fpm.sock;
                           fastcgi_param HTTPS $https; # <-- add this line
                           fastcgi_index index.php;
                           fastcgi_param SCRIPT_FILENAME $request_filename;
                           include /etc/nginx/fastcgi_params;
                           fastcgi_param PATH_INFO $fastcgi_script_name;
                           fastcgi_buffer_size 128k;
                           fastcgi_buffers 256 4k;
                           fastcgi_busy_buffers_size 256k;
                           fastcgi_temp_file_write_size 256k;
                           fastcgi_intercept_errors on;
                   location ~* ^/horde/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
                           root /var/www/;
            location /webmail {
                   rewrite ^/* /horde last;
    I have add:
    /var/www/horde to -> basedir...
  2. srijan

    srijan New Member HowtoForge Supporter

    Please check the thread, it might help you.
  3. felan

    felan Member HowtoForge Supporter

    Hmm.. My main problem is:

    pear channel-discover
    Discovering channel over http:// failed with message: channel-add: Cannot open "" (Connection to `' failed: Connection timed out)
    Trying to discover channel over https:// instead
    Discovery of channel "" failed (channel-add: Cannot open "" (Connection to `' failed: Connection timed out))

    And this on a fresh install :/
  4. dcurrey

    dcurrey Member

    Are you resolving addresses correctly?


    Should come back with an ip of
  5. felan

    felan Member HowtoForge Supporter

    Hi dcurrey.

    mike@testserver:~$ host is an alias for has address
  6. dcurrey

    dcurrey Member

    Any type of firewall running that would prevent you from accesses remote port 80 and 443?

    If not other than some sort of temporary pear / connection error I am out of ideas.
  7. felan

    felan Member HowtoForge Supporter


    No no problems like that. I can import other channels, just not Horde.

    Problem solved. In case anyone else gets this issue, stop fail2ban.
    Last edited: Jul 25, 2014

Share This Page