Install Script fails (Debian Buster + Bullseye) - GoAccess repo

Discussion in 'Installation/Configuration' started by Tom4S, Oct 11, 2021.

  1. Tom4S

    Tom4S New Member

    Hi guys,
    the install script for automated install fails every time, I tried on Debian 10 and 11. I ran the command

    wget -O - xttps://get.ispconfig.org | sh -s -- --use-nginx --use-ftp-ports=40110-40210 --unattended-upgrades

    and I always get this error message:

    WARNING! This script will reconfigure your complete server!
    It should be run on a freshly installed server and all current configuration that you have done will most likely be lost!
    Type 'yes' if you really want to continue: yes
    [INFO] Starting perfect server setup for Debian GNU/Linux 10 (buster)
    [INFO] Checking hostname.
    [INFO] Enabling contrib and non-free repositories.
    [INFO] Updating packages
    [INFO] Updated packages
    [INFO] Installing packages ssh, openssh-server, nano, vim-nox, lsb-release, apt-transport-https, ca-certificates, wget, git, gnupg, ntp
    [INFO] Installed packages ssh, openssh-server, nano, vim-nox, lsb-release, apt-transport-https, ca-certificates, wget, git, gnupg, ntp
    [INFO] Activating rspamd repository.
    [INFO] Activating sury php repository.
    [INFO] Activating GoAccess repository.
    [ERROR] Exception occured: ISPConfigOSException -> Command echo "deb xttps://deb.goaccess.io/ $(lsb_release -cs) main" | tee -a /etc/apt/sources.list.d/goaccess.list >/dev/null 2>&1 ; wget -O - xttps://deb.goaccess.io/gnugpg.key 2>&1 | apt-key --keyring /etc/apt/trusted.gpg.d/goaccess.gpg add - 2>&1 failed. (/ispconfig.ai.php:15)
    I installed in LXC on Proxmox, using the Standard Debian Image. Any ideas?

    Thx
    Tom

    (had to replace https with xttps since I am not allowed to post links ..)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Run the command manually to see why it fails on your system. Maybe your harddisk is full, or you have a problem with limitations in LXC, just to name a few possibilities.

    Code:
    deb xttps://deb.goaccess.io/ $(lsb_release -cs) main" | tee -a /etc/apt/sources.list.d/goaccess.list >/dev/null 2>&1 ; wget -O - xttps://deb.goaccess.io/gnugpg.key 2>&1 | apt-key --keyring /etc/apt/trusted.gpg.d/goaccess.gpg add - 2>&1
     
    Tom4S likes this.
  3. ahrasis

    ahrasis Well-Known Member

    Install in a vm should work fine.
     
    Tom4S likes this.
  4. Tom4S

    Tom4S New Member

    Hey guys,

    thank you for your quick replies! I tried with a Debian 11 KVM, got exactly the same error message.

    df command gives results:

    Filesystem 1K-blocks Used Available Use% Mounted on/dev/loop2 25626852 1044452 23255296 5% /
    none 492 4 488 1% /dev
    udev 32783028 0 32783028 0% /dev/tty
    tmpfs 32814616 0 32814616 0% /dev/shm
    tmpfs 32814616 8272 32806344 1% /run
    tmpfs 5120 0 5120 0% /run/lock
    so disk space should not be a problem I guess?

    Running this command manually gave this error message:

    -bash: deb xttps://deb.goaccess.io/ buster main: No such file or directory
    gpg: no valid OpenPGP data found.
    So I tried to ping deb.goaccess.io but got error
    connect: Network is unreachable​

    Well, it seems to be a problem that I only setup my server with IPv6. deb.goaccess.io has no AAAA record set. Same problem on github, by the way. Okay, seems like I have to find a way to setup IPv4 first ...
     
    ahrasis and till like this.
  5. Tom4S

    Tom4S New Member

    Ok guys,

    1) KVM
    After having a hard time reconfiguring my IPv4 setup, I finally made it! In the KVM the script finished without errors and I was able to login to ISPConfig. So thank you very much for helping me!

    2) LXC
    In the (unprivileged) container, the script failed again .... After running the command

    wget -O - xttps://get.ispconfig.org | sh -s -- --use-nginx --use-ftp-ports=40110-40210 --unattended-upgrades --debug​

    I get only the unspecific error

    [INFO] Writing MySQL config files.
    [INFO] Configuring postfix.
    [INFO] Restarting postfix
    [INFO] Installing packages software-properties-common, dnsutils, resolvconf, clamav, clamav-daemon, clamav-docs, zip, unzip, bzip2, xz-utils, lzip, rar, arj, nomarch, lzop, cabextract, apt-listchanges, libnet-ldap-perl, libauthen-sasl-perl, daemon, libio-string-perl, libio-socket-ssl-perl, libnet-ident-perl, libnet-dns-perl, libdbd-mysql-perl, bind9, spamassassin, rspamd, redis-server, postgrey, p7zip, p7zip-full, unrar-free, lrzip
    [ERROR] Exception occured: ISPConfigOSException -> Installing packages failed. (/ispconfig.ai.php:15)​

    My question, since I don't want to attempt the squaring of the circle: Is there any chance of installing ISPConfig in a standard LXC template container on Proxmox? Any recommendations for doing that?
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    As a yes or no question, I'd say yes, there's likely a chance you could do so. I haven't installed in LXC in a while, and am actually actively converting all our lxc containers to vm's.
    Only, "don't" - I'd recommend installing in a vm up front.
     
    Tom4S likes this.
  7. ahrasis

    ahrasis Well-Known Member

    As said earlier.
     

Share This Page