Installation almost worked :)

Discussion in 'Installation/Configuration' started by awerner, Nov 10, 2005.

  1. awerner

    awerner New Member

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/ on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

    So it appears like it thinks it worked correctly (after modifying the clamav compiler options to skip a spurious zlib error).

    however, at this point there is no data in the mysql schema and I can't login to my ispconfig as admin / admin .

    Is there a way to manually step through the final few steps (i.e. create the schema?)
  2. falko

    falko Super Moderator Howtoforge Staff

    I guess you tried to install more than once from the same sources. This doesn't work!
    You have to remove the current ISPConfig installation:
    rm -fr /root/ispconfig
    rm -fr /home/admispconfig
    Also delete the database you created during the last installation, or use another database name in the next installation.
    Then unpack the ISPConfig sources again, and run setup again.
  3. wizardofoz

    wizardofoz New Member

    What is needed this is what is needed...a simple how to recover from the last step that failed (and perhaps where it takes you safely back to) in the howto's ... so that we who are new to all this and flung in the deep end have some means to go back a step or 3 without having to do a full reinstall.

    Thanks Falko for the great work on what is might just make web hosts out of us yet!
  4. awerner

    awerner New Member

    well - almost a perfect recovery tip

    Since the thing that caused me to rerun the whole thing the first time was needing to include a --disable-zlib-vcheck in clamav this is not the complete

    I'm trying to decide now if I am supposed to untar the clamav version in the compile_apps directory, set that flag somewhere (where?), and retar the distro so it will work correctly on my machine.

    What is frustrating is I could install all those apps using Yum and be done!

    I just installed cacti on another machine - it's amazing that they were able to do the entire install using yum / apt and package dependencies - after which you run a d/b create script. I personally would much rather have all my installed software visible at that level (i.e. part of my rpm list) rather than continuing with the old way of just tar xzf; ./configure ; make install of old so you have no easy way to see what versions of software are installed, and where.

    Maybe the right thing to do is set up an rpm repository similar to DAG so users can install that way?
  5. awerner

    awerner New Member


    I am running CentOS release 4.2 (Final). The zlib was patched with the security fixes, but is not the latest version because of dependencies among all the software components (a common approach in Fedora/Redhat/Centos). That's why the clamav is balking - the version "may" have vulnerabilities based on the version number - it does not.
  6. awerner

    awerner New Member

  7. falko

    falko Super Moderator Howtoforge Staff

    You can either set that flag in install_ispconfig/compile_aps/compile, or have a look at this thread:

    ISPConfig needs these programs with special options so you cannot simply install the packages from your distribution.
    The reason why ISPConfig doesn't come as an rpm package is that you must provide some details during installation (IP address, host name, database details, etc.) because otherwise ISConfig would not work.
    Nomally, when you install rpm packages, you aren't asked any questions.

Share This Page