Installation Of Ispconfig

Discussion in 'Installation/Configuration' started by snake911, Dec 1, 2005.

  1. snake911

    snake911 New Member

    Alright guys i have mandriva 10.2 install!! i have all the software installed that is needed for the installation of ispconfig but i am getting this error:

    tar: /root/ispconfig/install_ispconfig/compile_aps/../binaries/aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    ./compile: line 111: 5230 Broken pipe tar -pczf ${COMPILE_DIR}/../binaries/aps.tar.gz ${APPLICATION_NAME}_tmp
    ERROR: Could not create aps.tar.gz
    ./compile: line 55: cd: /root/ispconfig/install_ispconfig/compile_aps: No such file or directory

    I have no idea what is going on?? Need any kind of help possible. My main goal is to get imap up and running and i was told ispconfig was the way to go. If that is wrong please let me know.

    Any help would be kindly appreciated!!!!
  2. falko

    falko Super Moderator Howtoforge Staff

  3. snake911

    snake911 New Member

    i redid it like the howtos said and i still get that error!!!!!!! I am at a loss on this one!!!!! it seems to be looking for a file that is not there!
  4. falko

    falko Super Moderator Howtoforge Staff

    Hm, I think the problem is that you're trying to install from /root/ispconfig. Choose another directory, e.g. /tmp, then unpack the ISPConfig sources there, go to install_ispconfig and run

    Make sure you delete /root/ispconfig and /home/admispconfig before if they exist.
  5. snake911

    snake911 New Member

    well i just did what you suggested and i got to same place but with different error here is the error this time:

    Installing build environment: /root/ispconfig/php/lib/php/build/
    Installing header files: /root/ispconfig/php/include/php/
    Installing helper programs: /root/ispconfig/php/bin/
    program: phpize
    program: php-config
    program: phpextdist
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking target system type... i686-pc-linux-gnu
    creating target.h - canonical system defines
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... configure: error: newly created file is older than distributed files!
    Check your system clock
    ERROR: Could not configure ClamAV

    I did what you said and unzipped it in the /tmp and the above error is what i got. i dont understand why do i have to look at system clock. i just gues this wants to give me a hard time????
  6. falko

    falko Super Moderator Howtoforge Staff

    You have to update your system time! Run
    to find out your current system time. If the ClamAV sources are from a newer date than your system time then ClamAV complains... ClamAV is very finicky about this... :(
    On I describe how to update your system time.
  7. snake911

    snake911 New Member

    Well i got a little further this morning!!! Thank you so much for the help!!! But right now i have another error:

    ########## QUOTA ##########

    Checking for package quota...
    which: no quota in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    ERROR: quota not found!

    I remember seeing this on the forums somewhere but i cant find it any more.
    so any more help would be appreciated.

    All other advice has worked so far!!! thank you thank you!!!
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig needs the quota package. Install the quota package from mandriva, delete the rests of the failed install as described in the installation manual, unpack the installer tar.gz again and rerun the setup.
  9. falko

    falko Super Moderator Howtoforge Staff

  10. snake911

    snake911 New Member

    I am looking at it now and installing the stuff right in a row!!! I should of done this first!!!! I will let you know if it works!!!! I am working on it right now!!!
  11. snake911

    snake911 New Member

    well guys thanks for the help everything I think i got it!!! the installation got all the way till it started asking me questions about mysql and when i put in my sql password it was wrong so i think i have to set up my pw just like it says in the howto on the perfect setup so i am going to try it again and get back to you !!!!!
  12. snake911

    snake911 New Member

    alright two things guys:

    i followed the perfect mandrake how to and everything worked out and tested good except when i tellnet my local host to see if SMTP-AUTH and TLS work properly i got the following weirdness:

    [james@localhost ~]$ telnet localhost 25
    Connected to localhost (
    Escape character is '^]'.
    eh1o localhost

    I tellnet in and connects but when i type in the next comman eh1o localhost i get nothing. please tell me what i am doing wrong AGAIN !!!!

    So i continue on and install ispconfig and i get all the way till it ask me questions about mysql and for some odd reason its failing right there:
    ########## INSTALLATION ##########
    Preparing files. Please wait a moment...
    All prerequisites are fulfilled.
    Here we go...
    Please enter your MySQL server:localhost
    Please enter your MySQL user:root
    Please enter your MySQL password:
    Please enter a name for the ISPConfig database (e.g. db_ispconfig):db_ispconfig
    Please enter the IP address of the ISPConfig web (e.g.
    Please enter the host name (e.g. www):www
    Please enter the domain (e.g.
    ERROR: The URL is not reachable! The installation routine stops here!

    I really dont know what is going on here!!!!
    Again any help would be appreciated!!!!
  13. falko

    falko Super Moderator Howtoforge Staff

    First, it's
    eh[COLOR="Red"]l[/COLOR]o localhost
    , not
    eh[COLOR="Red"]1[/COLOR]o localhost
    Secondly, what's in /etc/postfix/ as myhostname and mydomain? myhostname/mydomain must exist in DNS!
  14. snake911

    snake911 New Member

    Ok guys I feel really stupid on the first question it worked. Also i finally got ispconfig installed and running and i was able to log into it. But i cant find anything on how to configure imap. I was told that ispconfig will give me the ability to edit and configure this protocal. Is this right or am in wrong and need to go another direction????
  15. falko

    falko Super Moderator Howtoforge Staff

    You don't have to configure imap at all. Just install it, start it, and then create users and email addresses, and the users should be able to login to your imap server.
  16. snake911

    snake911 New Member

    Not to be stupid or anything but is there any how to's on how to create users and email addresses. And then how users get access to that information. And how users are able to login to your imap server.

    I mean i am really really new at this imap and email thing on linux and how to do it.

    I did the install it part from the perfect set up guide for madriva/mandrake and i started it. But i cant find were to ad users and email addresses.

    Thanks for all your help guys.
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    No, there is no howto. Here the steps, all in the ISPConfig webinterface:

    1) create a client.
    2) create a website.
    3) Go on the user and email tab of this newly created website and click on new user. Fill out the name, username, email and password. Hit save.

    Now you can connet with the username (like: web1_newuser) and the password you entered for this user to the pop3 and imap account.
  18. falko

    falko Super Moderator Howtoforge Staff

  19. snake911

    snake911 New Member

    Ok well i did what you said i created a client created a site and then i created an email and now i dont know how test to see if the imap is working!!!! How do i send an test email or any email. Do i use a mail client or what do i do here i am lost again for the hundreth time. Of course i dont know any good email clients on mandriva?? So really i am in the dark on this question again....

    Can you guys help me out again?????

    Thanks again for the help prevously it work great so far.
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Why do you need an email client for Mandrive. If you have a windows workstation too you can stay with the mail client you used before. If you are looking for a mailclient for mandriva, have a look at thunderbird, kmail or evolution.

    Opem the mailclient of your choice, create a new account. Set incoming and outgoing server to the IP address or domain of your server. Select Imap in the account settings, enter username (the username looks like this web1_xxxxxx) and the password you entered as you creted the email address in ISPConfig. Now send an eimail to the address you created in ISPConfig.

Share This Page