Installing The VMware Management Interface

Discussion in 'Installation/Configuration' started by m1n1st3r, Jan 4, 2007.

  1. m1n1st3r

    m1n1st3r New Member

    Running Ubuntu 6.06 LTS (Dapper Drake) Server.

    I followed the How-to to install VMWare Server Web Management Interface.

    Installation completed without errors, everything works great, got several vm's up and running, There is just one small exception. When I reboot, the Web Management Interface running on ports 8222 and 8333 does not load/respond.

    I ran nmap and noticed that these ports are not even open.
    After reboot if i run the command "/usr/bin/" everything works great again.

    I was wondering how I should debug this, and what exactly the command "/usr/bin/" does.

    Please forgive me, I'm really new to Linux. Any help would be appreciated.
  2. m1n1st3r

    m1n1st3r New Member


    After some digging I final found the fix.

    Add the following to the end of etc/init.d/rc

    # vmware httpd fix <<start>>
    mkdir /var/run/vmware/httpd/
    chown www-data /var/run/vmware/httpd
    chgrp nogroup /var/run/vmware/httpd
    chmod 700 /var/run/vmware/httpd
    /etc/init.d/httpd.vmware start
    # vmware httpd fix <<end>>

    Reboot, Drink beer, life is good.

Share This Page