Ioncube problem

Discussion in 'Installation/Configuration' started by Dag Andresen, Oct 5, 2009.

  1. Dag Andresen

    Dag Andresen New Member


    I'm trying to install ioncube, I have followed their instructions but it seems like the ioncube isn't loaded...

    I'm recieving these errors when trying to open an encoded file:

    Anyone know what this is all about? open_basedir restriction?

    Also what is the correct folder to put the ioncube files into? I tried everything from usr/lib64/php/modules/ioncube to /var/www/ioncube and /usr/local/lib/ioncube....

    Everytime I have edited php.ini file accordingly and restarted apache, without luck.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linuxdistribution and which php.ini file did you edit? Also which PHP mode did you use for the wesbite?
  3. Dag Andresen

    Dag Andresen New Member


    I managed to get ioncube work, however I'm still recieving the "open_basedir restriction in effect" error. I tried to edit the vhosts file with mixed sucess (all errors disappeared when I disabled open_basedir, however as far as I know this isn't safe).

    Do you know how to remove this error? What's the correct way?

    This is my info:
    PHP Version: 5.1.6
    Operating System: Linux
    Threaded PHP: No
    php.ini file: /etc/php.ini
    Required Loader:

Share This Page