IP address get removed in domain settings !!!

Discussion in 'Installation/Configuration' started by Keoz, Feb 11, 2021.

  1. Keoz

    Keoz Member

    *** MY ENVIRONMENT ***
    Machine : VPS 2vCore
    OS distro : Ubuntu 18.04 LTS
    Server : Apache 2.4
    Panel : ISPConfig 3.2.2 (up to date)


    When filling the relevant field, the correct IP address is by default displayed in scroll-down menu, I can then select it, and it remained set until I click the “Save“ button.

    But after the saving process gets terminated, when I re-open the “domain“ tab, I observe that the IP address was removed. This issue may be the reason why I can’t access my server from FTP client with FTP user created in ISPConfig.

    It is the first time that I installed ISPConfig 3.2 with the autoinstaller, with success apparently (using git). I then can testify that I never faced such this IP address issue with else installation method for ISPConfig 3.1.

    Autoinstaller (git method) : https://git.ispconfig.org/ispconfig/ispconfig-autoinstaller

    I don’t know what causes the issue (and need help to solve it), but maybe the autoinstaller is one track among others that should be investigated !

    Please help !
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No, this is not related to FTP in any way.

    This is also not related to the auto-installer at all.

    First, it is recommended to select always * in the IPv4 field. If you want to use an IP anyway (this might cause you access problems when using an IP instead of *), then you must add the IP address under system > server IP first.
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Maybe we should add a check to the query for the IP addresses to check wether this checkbox is enabled for the IP?
  4. Keoz

    Keoz Member

    *** SOLVED ***
    You're right !
    I did get the FTP issue solved after understanding that my hosting service provider now delivers VPS with higher default security settings than before….

    *** SOLVED ***
    Thank U, I did set the entry to * (all domains), and all is fine....
    *** Q1 ***
    Is this recommendation recent ?
    Because this field is set with specific IP address on all my oldest ISPConfig instances, and no problem at all….

    *** Q2 ***
    I found that it is already added by default, but there was no entry (empty field) for the client setting, so I set it to a registered client…. Should I then remove this add if I did set * instead of IP address under the domain setting tab ?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    It's like this for many years now. the problem is that if you enable an IP in apache or nginx, it will catch all requests for other domains that use *. Therefore it's better to not use the IP and use * instead. using the IP makes only sense if your server has multiple IP addresses and you set a dedicated IP for each website. But as IPv4 addresses are a rare good today, it has become very uncommon to have a dedicated IP per website and therfore, using * is the recommended option, as you may never mix * and IP addresses on a server within websites.

    No, just change it back the way that it was at install time.
  6. Keoz

    Keoz Member

    OK thanks.

Share This Page