ipsc 3: /which /hostname not found

Discussion in 'Installation/Configuration' started by InvaderZim, Sep 2, 2010.

  1. InvaderZim

    InvaderZim New Member


    I tried a fresh install as root over ssh on a gentoo-server.
    the setupscript is not working and i get these errors:

    sh: /which: No such file or directory

    sh: /hostname: Datei oder Verzeichnis nicht gefunden

    Notice: Undefined offset: 0 in /root/ispconfig3_install/install/install.php on line 115

    some outputs:
    # which which

    # which hostname

    # echo $PATH

    whats the problem?

  2. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig 3 does not support Gentoo.
  3. InvaderZim

    InvaderZim New Member

    i tested it in sabayon which is a gentoo binary-distro and it worked just fine.
    there is also a helper script for gentoo, but this is quite outdated.
  4. falko

    falko Super Moderator ISPConfig Developer

    I guess that the ISPConfig installer uses a PATH that doesn't work out on Gentoo, but that's just a guess.

Share This Page