IPv6 issue with ispconfig website?

Discussion in 'General' started by 00Kell, Nov 30, 2021.

  1. 00Kell

    00Kell New Member

    I am wondering if there is an issue with connecting to ispconfig.org via IPv6?

    I just tried to update using

    But after a while, I got the following rejection:
    Unable to retrieve version file.

    So I tried the manual route but wget wouldn't fetch. It did fetch for other websites though. It finally worked when I forced it to use IPv4:
    wget --inet4-only https://www.ispconfig.org/downloads/ISPConfig-3.2.7p1.tar.gz

    I am also wondering if it would be useful to have an IPv4 flag for the script. In my googling on the issue, I noticed that a couple of people may have had a similar issue.
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Does your host have IPv6 connection to the Internet? If not, you could disable v6 completely.
  3. 00Kell

    00Kell New Member

    It does.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig.org domain does not has any AAAA records. I wonder why your system tries to connect via IPv6 to a system that does not has any IPv6 DNS records instead of using IPv4?
  5. 00Kell

    00Kell New Member

    till likes this.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    These were not added by me explicitly, seems as if Cloudflare has added them automatically without displaying them in their GUI. Please try if the download works now for you without inet4 flag.
  7. 00Kell

    00Kell New Member

    Unfortunately not. I have tried flushing my cache but everything I try still provides AAAA records for www.ispconfig.com.

    So, the name servers appear to be:
    > whois ispconfig.org
    If I dig those servers directly for AAAA records I get:

    > dig AAAA @karl.ns.cloudflare.com www.ispconfig.org
    ; <<>> DiG 9.10.3-P4-Debian <<>> AAAA @karl.ns.cloudflare.com www.ispconfig.org
    ; (6 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49122
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1
    ;; WARNING: recursion requested but not available
    ; EDNS: version: 0, flags:; udp: 1232
    ;www.ispconfig.org.             IN      AAAA
    www.ispconfig.org.      300     IN      AAAA    2606:4700:20::ac43:4b70
    www.ispconfig.org.      300     IN      AAAA    2606:4700:20::681a:bf6
    www.ispconfig.org.      300     IN      AAAA    2606:4700:20::681a:af6
    ;; Query time: 8 msec
    ;; SERVER:
    ;; WHEN: Fri Dec 03 14:53:03 GMT 2021
    ;; MSG SIZE  rcvd: 130
    I assume that my server looks for AAAA records first by default as both ping and wget try to connect to them. I think that this is something that I chose when I set the server up but I really can't recall. It was a very long time ago now. If so, I can potentially look into setting IPv4 as the server's preference...
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    That's fine now as the traffic gest proxied to the server via ipv4. So normally it should work and I have not heard of any other systems that had trouble downloading things from ispconfig.org in the past, so something must be set up differently on your system which causes these issues.
  9. 00Kell

    00Kell New Member

    Oh well. ¯\_(ツ)_/¯

    Thanks for your help though!!!
  10. 00Kell

    00Kell New Member

    Funnily enough, I am still having this issue and have no idea why.

    I have updated to the latest version of IPConfig manually because my server wants to connect to ispconfig.org via IPv6 for whatever reason.

    Would it be possible to add something to ispconfig_update.sh to use IPv4?
    Either way, thank you very much Till for all your hard work. I really do appreciate it.

Share This Page