ipv6 mysql issue

Discussion in 'Installation/Configuration' started by Rein van 't Veer, Oct 24, 2015.

  1. Hey,

    I'm currently playing with a multiserver setup and testing some stuff.
    One thing I ran into is the hostname field for database access.

    I have a separate database server ( and a web server (
    both are also active on IPv6.

    Now I just moved a website from the (old) web server aka database server to the new web server. All of a sudden i got some unable to connect to the database messages which was for obvious reasons. I had not changed the database configuration yet in ispconfig. So I appointed the website to the database and tadaa, the remote ip of the web server is being filled in. I figured, lets's test again, but still no go. So i go CLI on the web server, and see: unable to connect from ipv6 address to database server... And when trying to add the ipv6 address of the web server, I get a invalid IP on the control panel...

    I'm sure one of you must have a fix for this ;-). Or to allow hostnames to be in the remote access field ;-). I do not want to disable IPv6 as it is the way to go in the future anyway ;-) Better be ready for it, especially with servers ;-).

Share This Page