isp is'nt able to delete a co-domain

Discussion in 'Installation/Configuration' started by tom, Apr 10, 2006.

  1. tom

    tom Member

    I've deleted one domain and already the domain shown in the paperbag as well.

    Then I was going to create the same domain again and a co-domain. This
    co domain can't by created because there is already the same domain.

    What I've to do to set up the new co-domain?

  2. tom

    tom Member

    Again I've deleted all user and web and now I get the notice when I try to create an new co-domain:
    By the way I've created a new email-account as well. Now, with the new account I'm not able any more to login in the webmail-account.
    but they are right. I used them for the same old account.

    Ähmm that seems to be a bug?
    How can I fix it?

    Last edited: Apr 10, 2006
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont think that there is a bug, looks like your system or ISPConfig database is messed up or you entered the wrong login details.

    In webmail you must enter the email address and password, not the email username.
  4. tom

    tom Member

    I knew the login data, but were are the solution for the strange performance. That's a completely new system an installation.

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    empty the recycle bin.
  6. tom

    tom Member

    I've deleted one domain and already the domain shown in the paperbag (recycle bin) as well.

  7. falko

    falko Super Moderator Howtoforge Staff

    Did you use the search function to search for the domain? It must be somewhere in your system.

    Did you make manual changes to the ISPConfig database?
  8. tom

    tom Member

    But now I've removed the entrys in the databas manualy and I can create and remove them as I would like to.

    I don't no why I couldn't it before.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    That was a really bad idea. If you do not delete the corresponding records in the tables isp_nodes and isp_dep you will corrupt your database.
  10. consumercitizen

    consumercitizen New Member

    Domain Belongs to another client

    Hi there,

    I'm having a similar problem. I have a domain setup like this.

    and am trying to add a co-domain without host so that email addresses of the form [email protected] resolve correctly. (as oppose to [email protected])

    but get the error:

    The name is already in use by another site or domain.
    The Domain belongs to another client

    The domain does not appear elsewhere through search. I have tried completely removing the domain, and emptying the trash and then reinstalling it.

    I was still not able to add the co-domain.

    checking for instance /etc/postfix/virtusertable I could see the domain existed as:

    In the Basis tab I then changed the host from




    this worked without error, however it showed


    instead of a blank for hostname in the Basis form, and the reseller login even though /etc/postfix/virtusertable now shows

    now I try to add as a co-domain and get.

    "The Domain belongs to another client."

    so I deleted the domain again.

    Now it doesn't show up in searches but there it is in db_ispconfig..

    select domain_host, domain_domain from isp_isp_domain;


    I guess this is a rogue entry here in the db.

    I have run check, optimise and repair db from the management tools all of which gave no error.

    So I was about to remove the entry from isp_isp_domain, but the thread mentions this is a really bad idea.

    How can I do it cleanly taking the records from isp_nodes and isp_dep as well?


Share This Page