ISP Links, but Doesnt Sync!!!

Discussion in 'Installation/Configuration' started by Connor Greer, Mar 30, 2015.

  1. Connor Greer

    Connor Greer New Member

    Used ISPConfig3 before, screwed up and now having to reinstall it completely again.

    I have used the multi server set up with Debian 6 and now 7.4 and it installs fine, links up so i can see it on the control panel, but it doesnt get the OS type or do anything else, i once had this issue and i cant remember how i fixed it, i want the multi server set up so i can extend the systsem and put mirrors in at different locations etc.

    I have also waited for an hour to see if it just was taking its time, still not syncing up.

    Please Help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likeley you did not add the records for all nodes to /etc/hosts file on all servers. This causes that mysql fails to connect after installation.
  3. Connor Greer

    Connor Greer New Member

    Hi Till,
    As far as i can remember we didnt do this the first time as we have a semi-large install. We do however use DHCP and DNS to get IP's etc, is there a way of doing it without modifieing the hosts file, or could i please request that feature?

    Thank you.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It works with dns as well, but only if the dns resolution from all servers is identical, thats why we recommend to us ethe hosts files, so that master and slaves all get the same IP address for all hostnames. If it differs, then mysql rejects the connects from the slaves after initial install. you can test that on the slave, get the master login details from ISPConfig file and try to connect with the mysql command from slave to master and use the exact hostname, ispcsrv* user and password from file for the connection.

Share This Page