isp manager - can't create reseller, client, hosting plan etc

Discussion in 'Installation/Configuration' started by ahuen, Sep 2, 2005.

  1. ahuen

    ahuen New Member


    I just got the ISPConfig 2.0.8 installed and when I tried to create a reseller, client, hosting plan, new site etc in the ISP manager section i get "The requested document type does not exist" I looked in the php file ispconfig\web\isp_kunde\new\kunde.php and it seems like it is refering doctype_id =1012 and i checked in my db the doc definition is there.

    in kunde.php
    header("Location: ../../multidoc/edit/edit.php?doctype_id=1012&s=$s");

    pls help.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you disabled cookies in your browser?
  3. ahuen

    ahuen New Member

    Cookie is enabled. Still no go. pls help.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Can you please try another browser (e.g. firefox) with default security settings.

    the error "The requested document type does not exist" is shown when you call a non existant document type or when the doctype_id variable is empty.

    Have you cnahnge settings in the php.ini of the controlpanel PHP?
  5. ahuen

    ahuen New Member


    just tried in firefox. got the same error. i did not change the php.ini.
    however when i did the install of ISPConfig it did not load the tables or data. I had to run the install_ispconfig/db_ispconfig.sql manually. It could be data related.

    Can I get a db dump for a clean install, if you have one?

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    OK, that makes the situation clearer. No, you cant install ISPConfig by installing the sql-dump manually. Please uninstall ISPConfig by executing:


    Then reinstall ispconfig. If you get any errors or problems, post them here we will help you to get around them.
  7. ahuen

    ahuen New Member


    Thanks for the heads up but it there we no error messages for creating the db. I tried reinstalling many times and it behaves the same way. Please advice.

    Ientered the following values and no errors.

    Please enter your MySQL server: localhost
    Please enter your MySQL user: root
    Please enter your MySQL password: mypassword
    Please enter a name for the ISPConfig database: ispconfig_db

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have any exotic characters in your mySQL password? If so, please change it for the setup. You can change it later in the ISPConfig config file.

    Have you disabled "skip-networking" in your mySQL configuration? I(SPConfig connects via TCP sockets on localhost.

    Before you reinstall, delete ispconfig_db or use an other db name for the next install, dont know if this can cause trouble :confused:
  9. ahuen

    ahuen New Member


    when i did the uninstall it says

    No results found!

    I am whacking the db, and reinstalling ispconfig.

    Will let you know the results.

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    If the uninstall script does not work correctly, delete the two directories


    manually before you reinstall.
  11. ahuen

    ahuen New Member


    Just reinstalled and it did not create the db.

    Connected successfully to MySQL server
    Es ist schon eine Datenbank mit dem Namen db_ispconfig vorhanden!
    Restarting some services...
    /usr/bin/apachectl restart: httpd restarted
    Shutting down postfix: [ OK ]
    Starting postfix: [ OK ]
    Shutting down proftpd: [ OK ]
    Starting proftpd: [ OK ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/ on line 47
    No results found!FreshClam is already running!
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

    this is the output
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    please send me the install log file as PM. The logfile is /var/log/ispconfig_install.log
    If there are any passwords inside, please xxxx them out.
  13. ahuen

    ahuen New Member


    Thanks! it's working.. i had to drop the schema of the db not just drop the tables. i saw that error in the log

  14. falko

    falko Super Moderator Howtoforge Staff

    netstat -tap
    show an entry for MySQL? You need to run MySQL over TCP, not over local Unix sockets! This is referring to what Till posted before:


Share This Page