ISP3 <> ISP2 zone transfer problem

Discussion in 'Installation/Configuration' started by t.roijers, Jul 28, 2011.

  1. t.roijers

    t.roijers Member


    We had two ISPconfig2 name servers. now we replaced the master name server with an ISPconfig3 name server.

    The ISPConfig2 slave server gets permission denied for zone transfers.
    I already updated named.conf.options on the master and included:

    allow-transfer { ipadres-of-slave-dns; };

    still permission denied, both running bind9 on ubuntu 10

    Please help!
    Last edited: Jul 28, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to add the IP address of the slave server in the "Allow zone transfers to
    these IPs (comma separated list)" Field of the dns settings of the zone in ISPConfig.
  3. t.roijers

    t.roijers Member

    Do i have to do this for every record???? or is their a main setting for all the records.
  4. giftsnake

    giftsnake New Member

    same question here!

    leaving the field empty results in
    allow-transfer {none;};
    overriding the setting in named.conf.options.

    maybe a feature request:

    • instead of "none;" insert default IPs

    • if empty, do not provide the "allow-transfer" option explicitly.
  5. t.roijers

    t.roijers Member

    That would be nice :)
  6. giftsnake

    giftsnake New Member

    what one could do:
    edit file
    and replace
    $options .= "        allow-transfer {none;};\n";
    $options .= "        allow-transfer {IP1; IP2; IP3;};\n";
    but I guess this change will vanish when updating ispconfig...
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Instead of editing the ispconfig code, you can set the options directly in dns file template. So you changes dont get overwritten.
  8. giftsnake

    giftsnake New Member

    is there a simple way to find out all possible options for the template file?

Share This Page