ISPC 3.1 cant renew LE certs

Discussion in 'General' started by Remko, Aug 9, 2017.

  1. Remko

    Remko New Member

    I've setup a perfect server with Ubuntu 16.04, apache 2.4, MariaDB 10, ISPC 3.1 etc.
    ISPC is running several websites without problems for some time now, except for this:

    After a while I added a ssl certificate to some of them, using the LE checkbox in ISPC.
    All worked great until the certificates had to be renewed.

    LE says all domains can't be verified in ISPC log.
    When running from the command line LE says <domain>/.well-known/acme-challenge/xxxxxx can't be found.
    When I place a testfile in /usr/local/ispconfig/interface/acme/.well-known/acme-challenge I can open it just fine.
    So why can't LE find its files?
    I've checked the LE and ISPC logs but can't find anything relevant to the cause of the problem.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that you are using ISPConfig 3.1.6, update to this version if your version is older. Then disable LE in that website, save the site, and then enable LE again.
  3. Remko

    Remko New Member

    Already updated ISPC to 3.1.6 and tried disabling and re-enabling LE before and after the update several times.
    Every time I see the same in the logs.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Is your server behind a router? If yes, then you have to enable the option "disable LE check" under System > server config > web.
  5. Remko

    Remko New Member

    Enabled "disable LE check" and checked LE again in the domain after.
    LE is checked now, but the certificate still isn't renewed.
  6. Tuumke

    Tuumke Active Member

    Post logs so we can check?
  7. Remko

    Remko New Member

    I've tried to request a new certificate for another domain on the same server.
    That isn't working either. I guess due to the same reason.
    Attached are ispconfig.log and letsencrypt.log

    Attached Files:

Share This Page