ISPC php.ini settings have no effect

Discussion in 'General' started by rfnx, Dec 9, 2023.

  1. rfnx

    rfnx New Member

    Hi,

    That changes of the php.ini files is always an endless game as the custom php.ini settings in ISPC are not applied.
    I have all PHP versions installed.

    I tried to do settings over the Custom php.ini settings in ISPC but it didn't succeed.
    Changed it in the php.ini file that phpinfo.php shows - no effect.

    Now I found out that I could set the PHP parameters globaly in ".php-fcgi-starter" but its write protected.
    upload_2023-12-9_3-44-41.png

    The same issue always reoccurs for whatever site!

    The strangest thing about the story is that the phpinfo shows that upload_max_filesize is set to 80G for
    /etc/php/8.1/fpm/php.ini wich I once set because of a nextcloud install, but the file itself shows
    ; but I allways get the message from every frontend that 2MB cannot be exceeded :(
    Cant find the php.ini with that 80G setting.
    All settings I do in the php.ini files are owerwritten after a reboot.

    can anybody please help me and tell me how I can

    1.) make the Custom php.ini settings working
    or
    2.) can edit .php-fcgi-starter as root?
    or best
    3) change the php.ini settings global?

    Thanks for you help!
     
    Last edited: Dec 9, 2023
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which operating system do you use?
    Which PHP version and PHP mode did you chose in that website?
    How did you install nextCloud and where did you installed it?

    That's not done by ISPConfog, so you must use another siftwre or Controlpanel that does this.
     
  3. rfnx

    rfnx New Member

    Debian8

    Version: PHP 8.1
    Mode: PHP-FPM

    I cloned it from github > https://github.com/nextcloud/integration_gitlab

    I just installed Debian 8 and kept it updated
    But I don't use the server alone, just ant imagine the 2nd user did anything there. he knows less than me about OSs and is about to have Web programming course; as far I know nobody else has access ...
    But I wrote him to ask if there was anything changed ;)
     
    Last edited: Dec 9, 2023
  4. rfnx

    rfnx New Member

    No he didn't change anything on the server!

    Is it possible that this is due to the Nextcloud clone?
    Planning to install the server new with Debian 11 & ISPC, but this time ISPC not with the install script but by cloning from github ..

    Just want to be sure that there are no problems with the compatibility between IPSC and Nextcloud ...
     
  5. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    This is not advisable.
     
  6. rfnx

    rfnx New Member

    For what reason?

    Usually one can manage multi-repo scenarios in the same way as when working with a single repository ...
     
  7. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    You might end up not using the ISPConfig stable version that way, so it is advisable to follow the tutorial instead, which will install the stable version.

    Also, please consider using latest Debian version too, which 12, instead of 11, that you are planning to use.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you either have other software that resets php.ini or the php.ini has not been reset.

    Not sure what you mean with nextcloud clone. Which tutorial did you use to install nextCloud and where exactly did you install it.

    Makes no sense at all for two reasons. First, do not use an outdated Debian version, the current Debian version is Debian 12. Using the auto-installer ensures that you get a perfectly installed and fully working system. You can not simply clone ISPConfig from git. This will not result in a working system, it just downloads you a bunch of code that does nothing.

    There are no issues with running nextCöoud on an ISPConfig server.

    Back to your original issue, there a quite a few misunderstandings on your side about how a recent Web server system works. Custom php settings for PHP-FPM are never in a fcgi starter file, they are always in the pool file of the php-fpm process, and ISPConfig adds them there. That you did not see these changes getting applied means that you likely made mistakes with your nextcloud installation, you probably copied any nextcloud apache config files onto your server that run nextcloud as the wrong user outside of the ISPConfig website.

    And when ou want to change php.ini settings globally, edit the matching php.ini file (you can see which file is used e.g. by placing a .php file with phpinfo() command inside in the website. And do not forget to restart the matching php-fpm process of that PHP version when manually ending php.ini file. When you use ISPConfig custom php.ini settings field, ISPConfig takes care to set the website specific info in the pool file instead and restart the php-fpm pool to apply them.
     
    Last edited: Dec 10, 2023
    ahrasis and rfnx like this.
  9. rfnx

    rfnx New Member

    Installed the server complete new but have now the same issue without Nextcloud plus another:

    I installed Debian 12 an used the "Perfect server for Debian 12" to install ISPC standalone.
    Tried to recover only the most important website but for any reason the php.ini settings are now missing in in ISPC.

    Tried to set upload_max_filesize in all php.ini files to 50MB & always restarted apache.

    Still no success!

    The issue now is that I cant recover the sites as the sql dump cant be imported with PHPmyadmin:
    upload_2023-12-11_6-50-22.png


    What am I doing wrong here?
     
    Last edited: Dec 11, 2023
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post a screenshot.

    You must restart the php-fpm service of that PHP version and not Apache when you edit php.ini for php-fpm, see my post #8
     
    ahrasis and rfnx like this.
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    They can be imported from command line, then there is no size limit.
    Not editing the correct php.ini -file or not restarting apache and phpmyadmin after the config change.
     
    ahrasis and rfnx like this.
  12. rfnx

    rfnx New Member

    OK After a new attempt to install ISPC it worked including the apache directives field and my fault was that I restarted Apache but not the php-fpm service
     

Share This Page