Ispconfig 2.1.2 on v2.2 database ?

Discussion in 'Installation/Configuration' started by bwrob, Mar 6, 2006.

  1. bwrob

    bwrob New Member

    I seem to have problems with v2.2, so i want to go back to v2.1.2
    Question is would v2.1.2 work on v2.2 modified database.
    I think it should.
    have mysql dump of first install of v2.2 database only.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What are the exact problems that you have. It might be a better solution that we try to fix them.

    Downgrading to 2.1.2 might be possible by runing the 2.1.2 installer again on your installation, but i dont have tested it. Make sure that you backup the database plus the directories /root/ispconfig and /home/admispconfig first (with preserved permissions!).
  3. bwrob

    bwrob New Member

    I tried 2.2 on 2 servers.
    One is suse 9.3 which was an upgrade from 2.1.2.
    Other server was a clean install of 2.2 on Debian sarge 3.1 in vps amd 64 server.
    On suse 9.3 upgrade went fine, but i tried to add an email address to to one site.
    Ispconfig database was updatet but email address like /home/www/webid_nu was not there.
    Yes i did inserted
    exec("maildirmake ".$web_path."/user/".$user_username."/Maildir &> /dev/null");
    exec("maildirmake -f Drafts ".$web_path."/user/".$user_username."/Maildir &> /dev/null"); in /root/ispconfig/scripts/lib/config.lib.php before i did anything.
    I had a full copy of 2.1 /home/admispconfig and /root/ispconfig so, i just copy it back to /home and /root respectively.
    Creating email now works just fine , but i wonder if the rest of it will work as well. So, i have ispconfig 2.2 modified database with ispconfig 2.1.2 os.
    Would this work ok. so far it is.
    :) it is on my web site
    On my Debian sarge 3.1 vps with 64M RAM 512M swap i gave up and went back to webmin virtualmin combo.

    Last edited: Mar 6, 2006
  4. falko

    falko Super Moderator Howtoforge Staff

    Email address? That's a directory... :confused:

    Please run
    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    on the shell. What's the output?
  5. bwrob

    bwrob New Member

    I did run

    server:/ # /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    ls: /etc/apache2/vhosts.d/*.conf: No such file or directory

    Hmm interesting.

    /etc/apache2/vhosts.d was orginally created by suse 9.3
    /etc/apache2/vhosts was created and is use by ispconfig 2.1.2

    Site is working fine with 2.1.2 using /etc/apache/vhosts dir

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The directory /etc/apache2/vhosts.d is not used in an ISPConfig setup.
  7. falko

    falko Super Moderator Howtoforge Staff

    That's ok. I was thinking that you maybe had a parse error in the file because you changed it, but if it is running then it's fine! :)

Share This Page