ISPConfig 2.2.11/FC 5 -- No Spam Scanning?

Discussion in 'General' started by anders_georgsson, Mar 28, 2007.

  1. anders_georgsson

    anders_georgsson New Member

    I have setup a machine with the excellent "Perfect Core 5" installation
    followed by the 2.2.11 ISPConfig installation but my system aren't
    scanning for spam! I have "MailScan" OFF,
    "Antivirus" and "Spamfilter" both ON ... I don't see any headers
    that would lead me to think it even went thru the filters.....

    Got any advice on what to look at?
    My /var/www/web1 has a .procmailrc that lists a number of
    "INCLUDERC" and on of them points to my

    Help :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The spam scanning headers are only added above a treshhold and not in every mail.

    To Test spamassassin, run:


    if it does not return any error everything is fine. You can then leave SpamAssassin by typing
    " CTRL + c".
  3. anders_georgsson

    anders_georgsson New Member

    Okay - so spamassasin is working .. but..?

    Thanks, Till: I tried running the spamassassin, and didn't get anything
    on my terminal, so I guess it's working... By what process is spamassassin
    called? I mean; Since spamassassin apperantly works - what makes the mail go through it... I'm used to seeing a .procmail in each users directory but apperantly ISPConfig does this in some other fashion.....

    Again, thanks for your help :)

  4. anders_georgsson

    anders_georgsson New Member

    Spamassassin - Perl problem?!?!?!

    When I run:

    cat ~web1_anders/Maildir/new/ | /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --prefs-file=/var/www/web1/user/web1_anders/.user_prefs

    I get:

    /usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/ undefined symbol: Perl_sv_2uv_flags

    What can I do about this?!

    /Thank You

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The error occurs in a file that belongs to your fedor 5 perl installation. Have you installed all fedora 5 updates for perl?
  6. anders_georgsson

    anders_georgsson New Member

    Not sure about the updates...

    I did quite a few updates before installing ISPConfig,
    would you know what package I'd have to check?

    As always - very thankful :) :eek:


  7. falko

    falko Super Moderator ISPConfig Developer

    I think you can run
    yum update
    This should install all available updates.
  8. anders_georgsson

    anders_georgsson New Member

    Thank You!!! Spamassassin works after updating!

    I ran "yum -y UPDATE" and it took quite a while,
    but it surely fixed it!! AWESOME help falko!
    Thank You! :D

  9. roadster

    roadster New Member

    I'm not getting any spam headers on a test account (early days with system setup!). I added the external account I was sending the test mail from to the spam blacklist for the test account ..... it just lets it through!

    I've run the command to test spamassassin and had no errors returned. Using FC5 Perfect Setup.

    Roadster Chris
  10. roadster

    roadster New Member

    Solved! This post proved useful:

    Running FC5 / Postfix. Needed to update Perl. Checked:

    /usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/ undefined symbol: Perl_sv_2uv_flags

    rpm -q perl spamassassin perl-Net-DNS

    perl-5.8.8-5 works fine:

    [19881] info: spamd: server started on port 783/tcp (running version 3.1.0)
    [19881] info: spamd: server pid: 19881
    [19881] info: spamd: server successfully spawned child process, pid 19883
    [19881] info: spamd: server successfully spawned child process, pid 19884
    [19881] info: prefork: child states: II

    X-Spam headers now in mails and blacklisted account identified.

    Roadster Chris
  11. unhookt

    unhookt New Member

    to update perl use the command:


Share This Page