ISPConfig 2.2.16 released

Discussion in 'General' started by till, Aug 27, 2007.

Thread Status:
Not open for further replies.
  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.16 is available for download.

    This ISPConfig release updates ClamAV to 0.91.2 and Spamassassin to 3.2.3.

    Detailed Changelog

    - Update: ClamAV to 0.91.2
    - Update: Spamassassin to 3.2.3
    - Added: Symlink for .user_prefs file to .spamassassin/user_prefs in the home
    directory of the email users to enable spamd to read the preferences.
    - Bugfix: Fixed a error message in the login script.



    Installation Instructions

    Download the ISPConfig-2.2.16.tar.gz from

    Installation on the shell as root User:

    tar xvfz ISPConfig-2.2.16.tar.gz
    cd install_ispconfig

    The installer automatically detects the installed ISPConfig version and performs an update.
  2. chuckl

    chuckl New Member

    The Sourceforge Dusseldorf mirror has a rather interesting ISPConfig-2.2.16.tar.tar file it's offering for download rather than the more usual .tar.gz
  3. till

    till Super Moderator Staff Member ISPConfig Developer

  4. chuckl

    chuckl New Member

    Till, I got the Dusseldorf Mirror by chance from the main ISPConfig page, and I'd downloaded it before I noticed the strange extension. I changed to Kent, and it was fine.

    From the UK, Dusseldorf is still offering a .tar.tar page (see attached screengrab).


    Attached Files:

  5. jsanglier

    jsanglier New Member

  6. edge

    edge Active Member Moderator

    Just updated all my servers (Debian Etch).
    No problems what so ever :)

    Thank you..
  7. Hans

    Hans Moderator ISPConfig Developer



    I just updated one of my servers with Debian Etch 64 bit without any problems! Thanks for the work again! :)
  8. daveb

    daveb Member

    Thanks, Updated without any problems.
  9. edge

    edge Active Member Moderator

    Oops.. Just found a bug, and I have the same problem on all my servers..

    It could be a local thing at my end (browser), but in Management, Web-FTP, Tools and Help the top icons are all missing...

    Again.. It could be a problem at my end. I only have at the moment one PC to access the servers with, so I can not test it with other PC's.
  10. Hans

    Hans Moderator ISPConfig Developer

  11. edge

    edge Active Member Moderator

    Hmmm I would have sworn that it used to have :)
    It must be an ID 10 T error on this side..

    Sorry for the panic.
  12. infamous

    infamous New Member

    Debian 4.0 32bits updated without problems.

    Thanks :)
  13. spuppy

    spuppy New Member

    Updating now.. this is making me nervous, as it looks EXACTLY like a full install I did the first time... so much text is flying by! Now it's asking me for the SSL info all over again
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    If it is asking for the SSL info, then its no update. Did you start the update more then once?
  15. spuppy

    spuppy New Member

    No, I just did the update.. it looked like it did a full install, but it's finished now and all the sites are working.
  16. payne

    payne New Member

    Got errors when updaiting:
    All prerequisites are fulfilled.
    Here we go...
    Warning: parse_url(https://): Unable to parse URL in /root/install_ispconfig/install.php on line                             678
    Connected successfully to xxx
    Warning: fopen(/root/ispconfig/httpd/conf/httpd.conf_): failed to open stream: No such file or directory in /root/install_ispconfig/install.php on line 91
    Warning: filesize(): stat failed for /root/ispconfig/httpd/conf/httpd.conf_ in /                                             onfig/install.php on line 92
    Warning: fclose(): supplied argument is not a valid stream resource in /root/ins                                             stall.php on line 97
    And now ispconfig not working,tried manually start with command /etc/init.d/ispconfig_server start but still not sense.
  17. omni

    omni New Member

    Update went smooth on my 32bit i686 Ubuntu 6.06.1 LTS machine.

    Thank you.
  18. falko

    falko Super Moderator ISPConfig Developer

    You can restore ISPConfig from the backups in the /tmp directory.
  19. Telesat

    Telesat ISPConfig Developer ISPConfig Developer

    Clamav and Spamassassin not working since upgrade to 2.2.16


    all the mail my server receives is marked like this:

    X-Virus-Status: Failed
    X-Virus-Report: /home/admispconfig/ispconfig/tools/clamav/bin/clamscan error 50
    X-Virus-Checker-Version: clamassassin 1.2.4 with clamscan / ClamAV 0.91.2
    Viruses are not being stopped and spam subject is not being rewritten.

    Looking at /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin I can see that the error 50 is issued here:

      2> /dev/null
    But I can't find the error 50 in the logs, and I don't know how to manually reproduce it in verbose mode.

    I'm using the 'Perfect Setup' for Ubuntu 7.04 Server 32bit (up-to-date).

    I've read the similar old threads* but I have not found any solution (I have no quotas for mailboxes).

    * and

    clamscan's behaviour is ok with the EICAR test file:

    [email protected]:~ ;)$ su - admispconfig
    [email protected]:~$ ls -la ./ispconfig/tools/clamav/bin
    total 616
    drwxr-xr-x 2 admispconfig admispconfig   4096 2007-09-07 17:20 .
    drwxr-xr-x 8 admispconfig admispconfig   4096 2007-02-23 17:39 ..
    -rwxr-xr-x 1 admispconfig admispconfig   6187 2007-08-30 02:30 clamassassin
    -rwxr-xr-x 1 admispconfig admispconfig   1071 2007-08-30 02:30 clamav-config
    -rwxr-xr-x 1 admispconfig admispconfig  45469 2007-08-30 02:30 clamconf
    -rwxr-xr-x 1 admispconfig admispconfig  78876 2007-08-30 02:30 clamdscan
    -rwxr-xr-x 1 admispconfig admispconfig 114428 2007-08-30 02:30 clamscan
    -rwxr-xr-x 1 admispconfig admispconfig 164440 2007-08-30 02:30 freshclam
    -rwxr-xr-x 1 admispconfig admispconfig 163981 2007-08-30 02:30 sigtool
    -rwxr-xr-x 1 admispconfig admispconfig  11287 2007-09-07 12:27 trashscan
    [email protected]:~$ wget
    [email protected]:~$ ./ispconfig/tools/clamav/bin/clamscan Eicar-Test-Signature FOUND
    ----------- SCAN SUMMARY -----------
    Known viruses: 150982
    Engine version: 0.91.2
    Scanned directories: 0
    Scanned files: 1
    Infected files: 1
    Data scanned: 0.00 MB
    Time: 1.208 sec (0 m 1 s)
    Thanks for your help :eek:

    PS I'll top post this so more people will see it.
    Last edited: Sep 7, 2007
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    The Clamav database can not be initialized. Either it is corrupted or the quota is too low:

    As the test with the eicar file worked for you, I guess the quota is to low. You will have to set the web quota of this mail user to a higher limit, so you have at least about 10 MB free space.
Thread Status:
Not open for further replies.

Share This Page