ISPConfig 2.2.20 released

Discussion in 'General' started by till, Feb 12, 2008.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.20 is available for download.

    This ISPConfig release adds support for Ruby and a Dutch translation of the user manual.
    Apache is updated to 1.3.41, mod_ssl to 2.8.31 and SpamAssassin to version 3.2.4.
    It contains many small enhancements and several minor bugs were fixed.

    Detailed Changelog

    - Added: Added Dutch user manual (thanks to Hans!).
    - Added: A global website statistics user can now be created under Management > Server > Settings > Other.
    The old admin:stats login (when a website had no users) was disabled.
    - Added: Added debugging messages to webalizer.php.
    - Added: A second failsafe configure string in case that the first attempt to run configure for clamav fails.
    - Added: "Keep Copy" check box to the "Forwarder" dialogue in the mailuser interface.
    - Added: Support for Ruby.
    - Added: open_basedir support to suPHP.
    - Update: Updated SpamAssassin to 3.2.4.
    - Update: Updated Apache to 1.3.41.
    - Update: Updated mod_ssl to 2.8.31_1.3.41.
    - Changed: Allow multiple A records for the SOA itself.
    - Changed: The "dienst_port" field in the isp_firewall table from varchar(10) to varchar(11).
    - Changed: Updated db.root.master and html-trap.rc.master.
    - Changed: Set ServerSignature to Off and ServerTokens to Prod in ISPConfig's httpd.conf.
    - Changed: New databases and database users will be created without underscores. (This doesn't affect existing databases.)
    - Changed: Opened port 143 (IMAP2) in the firewall by default.
    - Changed: Autoresponder doesn't respond to spam.
    - Changed: Autoresponder does not reply to [email protected] addresses.
    - Changed: Translated a German error message in the installer into English.
    - Changed: Non-CGI files (such as images, CSS files, etc.) can now be placed in the cgi-bin directory as well.
    - Bugfix: Fixed a bug in doctype 1027.
    - Bugfix: Fix some error with special characters (rev. 865 in dev)
    - Bugfix: Disabled userdir in ISPConfig's Apache.
    - Bugfix: Custom procmail recipes can now also be stored in /root/ispconfig/isp/conf/customized_templates.
    - Bugfix: If the creation of a zone fails due to an invalid admin email address, clear all records from that zone from the database.
    - Bugfix: Fixed SpamAssassin PATH problem on Mandriva.



    Installation Instructions

    Download the ISPConfig-2.2.20.tar.gz from

    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.20.tar.gz
    cd install_ispconfig

    The installer automatically detects the installed ISPConfig version and
    performs an update.
  2. Leszek

    Leszek Member

    Thanks again guys !!!
  3. edge

    edge Active Member Moderator

    Thank you.

    I'll install it later today on my servers.
  4. Hans

    Hans Moderator ISPConfig Developer

    ISPConfig 2.2.20 succesfully installed.

    Dear Till & Falko,

    Thanks again for this new stable release!
    I just upgraded 2 Debian Etch servers with ISPConfig 2.2.20 without any problem. Really nice that you integrated the Dutch documentation within the help section within ISPConfig already! :)

    Kind regards,
  5. pendexgabo

    pendexgabo New Member

    really really great work...
    tanks very much!

    simple question where can I read how give Ruby souport?

  6. t.roijers

    t.roijers Member

    SPAM Filtering ISPConfig 2.2.20 Release


    Does the ISPConfig 2.2.20 release support spamfiltering on forwarded mail?

  7. Hans

    Hans Moderator ISPConfig Developer

    Enable the "Ruby" checkbox on the basis tab of the site which needs support for Ruby. :)
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No. This is not supported in the 2.2.x series and will most likely not implemented for 2.2.x. ISPConfig 2.3.x (dev) and ISPConfig 3.x support the filteriung of forwarded mails for some time already.
  9. falko

    falko Super Moderator ISPConfig Developer

    I'll publish a tutorial this evening showing how to prepare your server for Ruby. :)
  10. Hans

    Hans Moderator ISPConfig Developer

    Problem after update to ISPConfig 2.2.20

    On my production server i make use of php5cgi+suPHP and php5mod as well.
    The sites which are using php5cgi+suPHP are working fine, but after the update to ISPConfig 2.2.20, the sites which are using php5mod are not working anymore.
    An internal server 500 error occurs. This affects my TYPO3 sites.

    The sites which are not using suphp have these lines within the apache directive field of the site:

    suPHP_Engine off
    RemoveHandler .php
    php_admin_flag engine on

    Everything always worked nice, untill my update to 2.2.20.
    What can be wrong?

    If i use php5cgi+suPHP and php5mod, what needs to be in the file /home/admispconfig/ispconfig/lib/

    1) $go_info["server"]["apache2_php"] = 'both';
    2) $go_info["server"]["apache2_php"] = 'addtype';
    3) $go_info["server"]["apache2_php"] = 'suphp';
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look in the error log of the website. Which error do you get there?
  12. Hans

    Hans Moderator ISPConfig Developer

    Problem solved, but weird....
    I disabled php for the TYPO3 website and enabled it again....After that all the TYPO3 sites where up and running again.
  13. Hans

    Hans Moderator ISPConfig Developer


    This where the errors wich occurd within the log file of the typo3 sites:

    [Tue Feb 12 14:14:28 2008] [error] [client 123.45.678.90] SoftException in Application.cpp:214: File "/var/www/typo3_src-4.1.5/index.php" is not in document root of Vhost "/var/www/web123/web"
    [Tue Feb 12 14:14:28 2008] [error] [client 123.45.678.90] Premature end of script headers: index.php

    For this reason i disabled/enabled php for the typo3 site to force ispconfig to write a new vhost file, which solved the problem... i only don't know how this could happen. But ... I am happy that the typo3 sites are up and running again in no time ;)
  14. jnsc

    jnsc rotaredoM Moderator

    which version of suPHP do you use?
  15. Hans

    Hans Moderator ISPConfig Developer

    @Till / Falko,
    The reason (i think) that the error occured, is that the line within the file /home/admispconfig/ispconfig/lib/ $go_info["server"]["apache2_php"] = 'suphp'; OR $go_info["server"]["apache2_php"] = 'addtype'; is overwritten with default line $go_info["server"]["apache2_php"] = 'both'; during an update of ISPConfig.

    I am almost sure, because i did not set the value to 'both' before.

    Due the update, also additional firewall rules where added.
    For this reason the imap port 143 was closed again, which i do not like, as i provide IMAP to my clients!

    I am using suPHP version 0.6.2.
    Last edited: Feb 12, 2008
  16. jnsc

    jnsc rotaredoM Moderator

    Ok I looked to me like the "Double free()" problem, but it has been resolved in 0.6.2
  17. SupuS

    SupuS Member HowtoForge Supporter

    Hi Falco and Till

    I just installed ISPConfig 2.2.20 on my new server. It was upgrade from previous version which I installed yesterday on clean Ubuntu 7.10 ;)
    Now I tried create databases under ispconfig but something is wrong. When creating I get always same name of database. For example for web1 ispconfig allways provides name web1db1 (without underscore) even if I creating seccond database. It is same for web2 too. I cannot create more than one database. Any idea please?

    Thanks .. SupuS
  18. Hans

    Hans Moderator ISPConfig Developer

    Due an old MySQL bug, which do still exists it was necesarry to remove the "_". For this reason, with the introduction of ISConfig 2.2.20 the "_" has been removed for new databases. This modification does not affect existing databases.

    If you only can create one MySQL database, probably you should increase the value from 1 to a higher value or -1 on the basis tab of the site within ISPConfig.
  19. falko

    falko Super Moderator ISPConfig Developer

  20. SupuS

    SupuS Member HowtoForge Supporter

    Hi Hans

    I set number of databases to 3 ( -1 is not awalable) but ispconfig still offer only:

    Database Name:  web1db1
    Database User:  web1u1
    when I want create new database (and web1db1 exists).


Share This Page