ISPConfig 2.2.25 released

Discussion in 'General' started by till, Aug 29, 2008.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.25 is available for download.

    This ISPConfig release adds an interface for creating PTR records. It contains many small enhancements and several minor bugs were fixed.

    Detailed Changelog

    - Updated Clamav to 0.93.3.
    - Converted linebreaks in to unix linebreaks.
    - Fixed a bug in the regex for the name of the user in the mailuser login.
    - Added turkish language files.
    - Replaced "AllowOverride None" with "AllowOverride Indexes AuthConfig Limit FileInfo" in the Python section of a vhost to allow .htaccess files.
    - Added option to redirect to a custom URL after logout from ISPConfig; the URL can be defined in /home/admispconfig/ispconfig/lib/
    - Added a second password field to the Mailuser interface to avoid typos when users try to change their passwords (password confirmation).
    - Changed Javascript code to stop loading the tree menu infinitely in some browsers.
    - Replaced deprecated configuration options from clamav.conf with new directives.
    - Added new section in the DNS Manager that allows the individual creation/management of PTR records.
    - Bugfix: "Create DNS" checkbox must not create A Record when the record is already existing as CNAME record.
    - Bugfix: DNS records were created when shell access was enabled and FTP disabled; this is now fixed.
    - Added domain name/hostname checks for slave and PTR records.
    - Bugfix: A bug in the spanish language files has been fixed.



    Installation Instructions

    Download the ISPConfig-2.2.25.tar.gz from

    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.25.tar.gz
    cd install_ispconfig

    The installer automatically detects the installed ISPConfig version and
    performs an update.
  2. edge

    edge Active Member Moderator

    Once again thank you for this update.
  3. pcotter

    pcotter New Member

    Thanks! Update went smooth in Debian etch.
    Keep up the good work guys!
  4. Norman

    Norman Member HowtoForge Supporter

    Update went fine on debian etch here.

    But on one SUSE 11 system the setup refused to compile due to the -mtune issue in openSSL.

    Now, when running the setup script again it did a complete reinstall of ispconfig rather than upgrade.
    But seemed to leave DB untouched from ver 2.2.24 . How can I manually update the 2.2.24 db to 2.2.25 ?

    I'll try setting the default-character-set=latin1 in my.cnf and run an update and see if it works.
    Last edited: Aug 29, 2008
  5. Norman

    Norman Member HowtoForge Supporter

    Update: seems to work now, adding PTR record displays properly rather than "document type not found".
  6. Hans

    Hans Moderator Moderator

    Update successful

    Last night, i've updated my two Debian Etch servers with ISPConfig 2.2.25. Everything went fine! Thanks for the nice work. :)
  7. commentator

    commentator Member

    Upgrade works ok on debian etch

    Upgrade not working on debian lenny.

  8. Norman

    Norman Member HowtoForge Supporter

    Workaround to get it to work on debian lenny:

    Go to compile_apps , unpack openssl-0.9.7m.tar.gz
    edit Configure and Makefile and change all instances of -m486 to -mtune=i486 .

    "tar -pczf openssl-0.9.7m.tar.gz openssl-0.9.7m" to repack dir, remove the unpacked directory.

    Make sure you do this before running ./setup on any upgrades in the future until this is fixed in ./setup package.
  9. matrixn

    matrixn New Member

    I have upgraded from 2.2.24 to 2.2.25 on SuSE 11.0 system and it works like a charm... i`ve got no errors during the setup...

    Thanks for this update...
  10. indie1982

    indie1982 Member

    I've got a few servers here running 2.2.23 and just wanted to know if anyone had any problems upgrading to 2.2.25 on Ubuntu Hardy Heron?
  11. acidh

    acidh New Member

    upgraded from 2.2.18 to 2.2.25, all went fine, exept the fact that php is stil at version 5.1.2, and not @ the supposed 5.2.6.

    Anyone has the same problem ?
  12. jnsc

    jnsc rotaredoM Moderator

    Do you talk about php that is running on the apache of ISPConfig (Port 81) or the one that is running on your apache that is serving your webpages (Port 80) ?
  13. indie1982

    indie1982 Member

    Trying to upgrade from 2.2.23 on an up to date Ubuntu Hardy Heron install I get the same error as commentator:

    And I noticed that at the start of the install it identified the system as Debian.

    Should I just make the changes that Norman suggests?
    Last edited: Sep 9, 2008
  14. falko

    falko Super Moderator Howtoforge Staff

    Yes, I'd try that.
  15. indie1982

    indie1982 Member

    When I re-run ./setup it says it is doing a new install and not an upgrade.

    How do I get it to upgrade and not do a new install?
  16. till

    till Super Moderator Staff Member ISPConfig Developer


    mkdir /root/ispconfig

    and then the setup script again.
  17. indie1982

    indie1982 Member

    Right I extracted the openssl files, edited the Configure and Makefile, removed the original archive, re-archived it, made /root/ispconfig and ran ./setup.

    I get the following:

    Any ideas where to go from here? I need to get the websites back up and running.

    Can I just reinstall 2.2.23 over 2.2.23? Would that work?
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that should work.
  19. indie1982

    indie1982 Member

    Well I tried to install 2.2.23 over the existing 2.2.23 installation and I get the same error message... Very odd.

    Here's my install log...

    I'm a bit worried about the line: WARNING: could not unpack ISPConfig system

    That's been in the log no matter which version I use 2.2.23, 2.2.25 or the modified 2.2.25.
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, this means that the problem is not caused by the new ispconfig version, there must have been something changed since the last install of 2.2.23.

    Please post the output of:

    df -h

Share This Page