ISPConfig released

Discussion in 'General' started by till, Jun 21, 2010.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is available for download. This release fixes some bugs that were found in ISPConfig For a detailed list of changes, please see the changelog section below.


    The software can be downloaded here:


    Known Issues:

    Please take a look at the bugtracker:

    BUG Reporting

    Please report bugs to the ISPConfig bugtracking system:

    Supported Linux Distributions
    - Debian Etch (4.0) - Squeeze (6.0)
    - Ubuntu 7.10 - 10.04
    - OpenSuSE 11 - 11.2
    - CentOS 5.2 - 5.5
    - Fedora 9 - 13


    The installation instructions for ISPConfig can be found here:

    or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.


    To update existing ISPConfig 3 installations, run this command on the shell:

    select "stable" as update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

    Detailed instructions for making a backup before you update can be found here:

    If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

    Manual update instructions

    cd /tmp
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    Last edited: Jun 21, 2010
  2. Franz

    Franz Member

    on multiserver setup, first update "slave" servers?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, slave servers should be updated first.
  4. Hans

    Hans Moderator ISPConfig Developer

    Thanks a lot for this new version!
    The upgrade from to went flawless on our Debian Lenny ISPConfig3 servers.
  5. Mike007

    Mike007 New Member

    CentOS 5.5 update without any problems, but log shows amavis error:
    same info after reboot system.
    Last edited: Jun 21, 2010
  6. racamet

    racamet New Member

    (excuse me for my poor English)

    I upgraded from version and I can not send or receive emails.

    Webmin shows me the following error:
    postfix: fatal: bad string length 0 <1: myhostname =

    How can I fix this?


    solved, had erased the name of the server in /etc/postfix/main.cfg
    Last edited: Jun 21, 2010
  7. guardian

    guardian Member

    Same here.
  8. ikrudolf

    ikrudolf Member

    When I try to update on my slave server it sais:

    What can be the reason for this?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig has a security mechanism that stops the update in case that the dumped sql database is too small to prevent that the update fauls due to problems with the databse dump. But sometimes this routines is wrong, e.g. if you have fery few records on the slave server.

    Please check the file existing_db.sql which has been created in the install folder during the ispconfig update if it seems to contain all data records that you would expect on the server, or if it contains nothing or just a error message.
  10. ikrudolf

    ikrudolf Member

    I tried to locate the existing_db.sql file but it doesnt exist?
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please use the manual update instruction as described above, you will find the sql file then in the install folder.
  12. ikrudolf

    ikrudolf Member

  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    cd ispconfig3_install/install
    ls -la
  14. ikrudolf

    ikrudolf Member

    MMM now I see the file.

    Strange when I type locate existing_db.sql it doesn't find it?

    And what should I do now with the existing_db.sql file?
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Locate uses a databse of all system files which gets updated nightly. So the file will show up with locate tomorrow.

    Regarding the original issue. Please take a look into the file existing_db.sql with atext editor. Does it look like all your records /sites email user etc) that shall be on this server are listed there?
  16. ikrudolf

    ikrudolf Member

    Tnx Till,
    Untill now I didn't add anything to the slave server, so no records added, sites or email, users etc. So this server is clean.

    What to do next to update to

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, this explains the problem. The database is smaller as the installer expects it to be as it is empty.

    You have to edit the update.php script and set the size limit to a lower vale. Edit line 152 and chnage it from:

    if(filesize('existing_db.sql') < 30000) .....


    if(filesize('existing_db.sql') < 20000) .......

    and then run the update.php script again.
  18. ikrudolf

    ikrudolf Member

    Tnx Till that did it.

    Can you tell me what this step does when I choose yes when I run the update.php script on the slave? (Because I still have some issues between slave and master, slave actions stay in the monitor.)

  19. till

    till Super Moderator Staff Member ISPConfig Developer

    This steps reconfigures the permission tables on the master database. As you have issues with these permissions, please run the manual update again and choose yes here.
  20. ikrudolf

    ikrudolf Member

    Did it.
    I keep with the problems that they stay in the monitor. I'm not getting this fixed..


Share This Page