ISPConfig 3.1 beta - PureFTPd authentication failed for every user

Discussion in 'Developers' Forum' started by gkovacs, Jun 8, 2016.

  1. gkovacs

    gkovacs Member

    Since manually downloading and upgrading my ISPConfig 3.0 installation to 3.1 beta, all FTP users have stopped working, trying any of them leaves the following error in /var/log/messages:

    Jun  8 12:01:47 appserver pure-ftpd: ([email protected]) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-GCM-SHA384, 256 secret bits cipher
    Jun  8 12:01:47 appserver pure-ftpd: ([email protected]) [INFO] PAM_RHOST enabled. Getting the peer address
    Jun  8 12:01:55 appserver pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [ftpuser]
    Changing the password of an FTP account to a new one does not help.

    I had the web interface login error as well, so I have already executed (git-stable) twice, once without reconfigure database, then with reconfigure. Neither of them helped.
    Last edited: Jun 8, 2016
  2. gkovacs

    gkovacs Member

    Solved by changing Pure-FTPd to use MySQL sockets instead of TCP. Not sure why it worked before...

Share This Page